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Section 1 - INTRODUCTION 
TexGraf4 is a companion graphics program for the UTEXAS4 slope stability 

analysis software.  TexGraf4 displays information from a slope stability analysis 
graphically on the computer display screen.  It also creates printed "hard-copy" output 
and DXF files that can subsequently be imported into suitable CAD software.  TexGraf4 
generates the graphics from information read from a special “Graphics Exchange” file 
created by UTEXAS4. 

This manual assumes that you have UTEXAS4 and are familiar with how to use 
it.  Before running TexGraf4 you must have created one or more suitable input data files 
and run them successfully with UTEXAS4 to create Graphics Exchange files. Additional 
details on using UTEXAS4 to create Graphics Exchange files are presented in the section 
below entitled "Creating Graphics Files with UTEXAS4." 

TexGraf4 is designed to run under Microsoft's Windows 95/98 and Windows NT4 
operating systems.  TexGraf4 uses the standard Windows graphical user interface.  
Menus are used to open and read the graphics file created by UTEXAS4 and to control 
and format what is displayed. 

Format and Style of this Manual 

Sections 1 and 2 of this manual give you a general overview of how to run 
TexGraf4 and how the software works.  More detailed information on specific features is 
then presented Sections 3 through 9 which follow. 

References in this manual to specific menus and menu items in TexGraf4 are 
generally highlighted in bold text.  Reference to specific items in a menu’s list are 
designated in the form File->Open, where "File" is the menu name that appears in the 
menu bar, and "Open" is the specific item in the menu. 

Some menus are hierarchical with sub-menus.  For example, the Settings->Line 
Weight menu item has a sub-menu with specific line weights.  One of the choices for line 
weights in the sub-menu is "hairline"; reference to this item in the sub-menu is 
designated in this manual as Settings->Line Weight->Hairline. 

References to specific keys on the keyboard (Enter, Shift, Esc) and "buttons" in 
dialog boxes  (Cancel, OK, etc.) are also shown in bold. 
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Creating Graphics Files with UTEXAS4 

TexGraf4 requires as input the special Graphics Exchange file created by 
UTEXAS4.  During a single session TexGraf4 can read multiple sets of data from a 
single Graphics Exchange file and read different sets of data from separate Graphics 
Exchange files.  All of the information read is stored in memory and can be displayed at 
the same time. Thus, you can "overlay" graphics from separate runs or problems.  Once 
the data have been imported and read into memory by TexGraf4 you can also selectively 
choose what information is displayed and/or printed from the information in memory. 

To create the appropriate Graphics Exchange files the input data files for 
UTEXAS4 must include the necessary Command Word "GRA" (GRAphics output).  The 
"GRA" Command Word directs UTEXAS4 to write the Graphics Exchange file for each 
set of data that exists when either the Command Word "COM" (COMPUTE) or the 
Command Word "NO" (NO COMPUTE) are issued in the UTEXAS4 input file.   

UTEXAS4 can perform computations for several problems from data in a single 
input file.  When this is done data for the various problems are all written to the same 
Graphics Exchange file, which can then later be imported into TexGraf4 in its entirety.  
Multiple problems can also be solved using data in separate input files for each problem.  
The choice to enter data in one input file or several different input files is entirely up to 
you and does not limit what you can later display in TexGraf4.  Computations with either 
form of input can eventually all be imported into TexGraf4 and displayed simultaneously 
if desired.  Similarly, when several sets of computation are performed with data from a 
single input file, results from only one of the sets of computations can be displayed alone, 
even though the Graphics Exchange file may contain results from several sets of 
computations. 

For each set of data read from either a single Graphics Exchange file or multiple 
Graphics Exchange files TexGraf4 adds a menu item to its "Utexas" menu (“Utexas” is 
one of the main menu items in TexGraf4's menu bar).  Ordinarily the text that is 
displayed in the menu for each set of computations is the text that is entered as a "Label" 
in the UTEXAS4 data input file.  If no Label text is entered, the menu text consists of the 
first approximately 60 characters of the first line of the Problem Heading entered with the 
UTEXAS4 input data.    The “Label” and “Problem Heading” data are entered as Group 
A data in UTEXAS4.  UTEXAS4 allows you to enter several separate problem Headings 
for even a given set of data, e. g. one problem heading may be entered for the Profile 
Line data and another one may be entered with the Analysis/Computation data. When 
multiple Problem Headings are entered for a given problem, the Problem Heading that is 
displayed as text in TexGraf4 will be the last Problem Heading that was read by 
UTEXAS4 before the computations were performed.  If neither a Label nor a Problem 
Heading is entered with the UTEXAS4 input data, the menu text for each data set is 
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shown as "Data Set Number xx (No heading or label)" where "xx" represents the number 
(1, 2, 3, etc.) of the data set read into TexGraf4; data sets are numbered in the order they 
are read by TexGraf4. 

Application Preferences 

Various default settings used by TexGraf4 are saved as "Application 
Preferences".  The Application Preferences include such things as what information is 
automatically displayed, the colors used to display various items, the style used to display 
lines, information on the format of DXF files, and the default directory path for finding 
the Graphics Exchange files.  You can save the current settings as the default Application 
Preferences at any time by choosing the File->Save Preferences menu item.  Each time 
TexGraf4 is started the Application Preferences are read and used to determine the 
default values. 

You can also save Application Preferences to a file of your choice and leter read 
the preferences to reset the current preferences to the ones that you have saved.  In this 
way you can setup a specific configuration (set of preferences) that you want to use and 
retrieve them when they are needed.  Saving and reading Application Preferences to 
either the default location or to a separate file are described in Section 3 for the File 
Menu items. 

Graphics Configuration File 

Information used to customize TexGraf4 is contained in a separate Graphics 
Configuration file named "TexGraf4.CFG".  This file is automatically read by TexGraf4 
at startup.  The Graphics Configuration file contains information on the optional line 
weights and point sizes that are displayed in the Settings menu.  It also contains the 
names of the "standard" line style names that will appear in the dialog box used to select 
line styles for the DXF file when the Settings->DXF File Line Styles menu item is 
chosen.   

All documentation for items in the Graphics Configuration file is contained as 
comments in the file itself.  The file is a text file that can be viewed and modified with 
any suitable text editor.  Before making such changes print out a copy of the file and 
study it.  Also, if you are going to change the Graphics Configuration file, be sure to 
make a secure backup copy of the file in case the changes you make produce errors or 
unintended results in TexGraf4. 
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Coordinate Systems 

Two independent systems of coordinates are used and referred to in this manual.  
The first set of coordinates are those used to define the problem in the UTEXAS4 input 
data.  These are referred to as “world” coordinates and are typically in units of feet or 
meters depending on the units (English, SI) used for the problem.  The second set of 
coordinates are those associated with the graphics display devices (monitor screen, 
printer, etc.).  These coordinates are usually expressed in units of “points”, inches, 
centimeters and millimeters.  These are referred to as “display” coordinates. 

Running TexGraf4 

TexGraf4 is started like any Windows application either by double-clicking on 
the TexGraf4.exe application in the Windows Explorer or by launching the TexGraf4.exe 
application by choosing Start->Run from the Windows Taskbar.  When TexGraf4 is 
launched it first displays the startup dialog containing license and version information.  
The information shown, including any information that the dialog may request will vary 
depending on the version of TexGraf4 you are using.  Once you have entered any 
information that the dialog requires or read any messages that are displayed, click the OK 
button to continue. 

Once the startup dialog is displayed and dismissed TexGraf4 reads the 
Application Preferences and the Graphics Configuration File containing information and 
default values for various variables described in this manual.  TexGraf4 then displays its 
main window with a Menu and Toolbar at the top and a Status Bar at the bottom.  
TexGraf4 is now ready to read information from the Graphics Exchange files created by 
UTEXAS4 and display the information.  The next section describes briefly how to get 
started with reading information into TexGraf4 and displaying it. 
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Section 2 - OVERVIEW AND GETTING 
STARTED 

Once you start TexGraf4 the main display window, menu, toolbar and status bar 
are displayed.  You are now ready to open and read information from Graphics Exchange 
Files which you have created using UTEXAS4.  To read the Graphics Exchange File go 
to the File menu and select Open.  A standard Windows dialog box is displayed for you 
to select the file to read.  Once you select a file and dismiss the dialog box by clicking the 
OK button, TexGraf4 proceeds to read all the data sets from the designated Graphics 
Exchange File.   

Once data are read from a Graphics Exchange File they are displayed in the main 
display window.  Ordinarily the items that are displayed depend on the default settings in 
the Application Preferences that were read at startup; however, if you have changed the 
default display selections using the Display->Selections menu item1, the items displayed 
will be those that you have chosen using the Display->Selections menu.  You may only 
change the default display selections by using the Display->Selections menu before any 
data are read or by reading in a new set of Application Preferences2. 

Each of the data sets that is read is identified by an entry in the Utexas menu in 
the main menu bar.  The labeling of each data set in the Utexas menu is described in 
more detail in Section 3, where the menus are described. 

"Current Data Set" 

TexGraf4 uses what is termed a "Current Data Set". The Current Data Set is the 
one that you can select items for by clicking in the display window.  Many of the settings 
that you make using various menu items are also applied to the Current Data Set. 

When data are first read into TexGraf4 from Graphics Exchange Files, the first 
data set read becomes the Current Data Set. If more than one data set is read, you can use 
the Utexas menu to choose which data set is the Current Data Set.  When you want to 
change the settings for a particular data set, you will normally first make that data set the 
Current Data Set by choosing it in the Utexas menu; then, you will change the settings. 

                                                 
1 The Display->Selections menu item is ordinarily used to set the display selections for the "Current" data 
set.  To use the Display->Selections menu item to set the default display selections, you must do so before 
any data have been read. 
2 New Application Preferences are read using the File->Read Preferences from File menu item. 
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The Current Data Set only affects what you can select and set options for; it does 
not refer to what is displayed.  Results from all data sets can be displayed at the same 
time if you wish. 

Menus 

The menus displayed by TexGraf4 at the top of the display window are used to 
control most of the functions of TexGraf4.  The function of each menu and menu item are 
described in Section 3 of this manual. 

Toolbar 

The main Toolbar contains a collection of small icons and is displayed at the top 
of the display window.  The Toolbar may be relocated by clicking and dragging it away 
from its docked location.  The left hand portion of the Toolbar supports a number of 
"Standard" windows functions including opening a file and printing what is displayed on 
the screen.  The right-hand side of the Toolbar contains a number of icons that are used to 
manipulate the display and control the display of "graphics grid3" points and lines for 
reference.  The function of these special Toolbar items is described in Section 4, which 
covers the Toolbar in further detail. 

Status Bar 

The Status Bar at the bottom of the display window has four panels used to 
display various information.  The left-most panel is used to display information about the 
items (icons) in the main Toolbar when the cursor is positioned over them.  It is also used 
to display information about each menu item when the menu is active and selections are 
being made by scrolling down the "popped-up" menu.  When an item in the display 
window is selected (by clicking on it) and the cursor is positioned in the display window 
(not in the menu or Toolbar area), the left-most panel of the status bar displays 
information about what is selected.  For example if a point on a Profile Line is selected,  
the number of the Profile Line, the number of the point, and the x,y coordinates of the 
point are displayed at the left of the status bar.  

The second two panels in the status bar, near the right hand side, are used to 
display the x-y "world" coordinates representing the current position of the cursor and 

                                                 
3 The “graphics grid” displayed by TexGraf for reference should be distinguished from the “search grids” 
that are used by UTEXAS4 to locate a critical circle.  The search grids are displayed as part of the problem 
information by TexGraf. 
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scale.  As the cursor is moved across the display window these coordinates are constantly 
updated.   

The last, right-most panel in the Status Bar is used to display quantities that are 
being "tracked" by the cursor.  Further details on what can be “tracked” and how the 
tracking display is controlled are given in Section 8 on Tracking. 

Selecting Items 

Items displayed in the main display window can be "selected" by clicking on 
them with the mouse.  Items can be selected to display information about them in the 
Status Bar, as described above, or they may be selected to set information about how the 
item is displayed.  For example to change the type and size of symbols used to display 
points on the Profile Lines, points are selected.  Similarly, to change the scaling used to 
display distributed loads on the surface of the slope, the distributed load is selected. 

To select an item, position the cursor over the item and click once.  If more than 
one "selectable" item exists at the point where you clicked, a menu "pops-up" with a list 
of the items at that location.  Use the menu to choose which item you want to "select."  
Once selected, the item will be highlighted and information on the item should appear in 
the left hand portion of the Status Bar. 

In general you can only select items that belong to the Current Data Set and are 
displayed (visible) in the display window.  The Current Data Set is chosen using the 
Utexas menu; the Current Data Set is indicated by a check mark opposite the item in the 
Utexas menu list. 
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Section 3 - Menus 
The main menu bar for TexGraf4  has the following eight menus, which are used 

to control many of the functions that TexGraf4 performs:  

• File 
• Edit 
• Display 
• Settings 
• Utexas 
• Window 
• View 
• Help.   

Each menu and corresponding list of items in the menu are described in the remainder of 
his section. t 

File Menu 

The File menu includes twelve static items plus the names of the six most 
recently opened files.  Each of the items is described below. 

New… 

The New menu item clears from memory all data that have been read to this point 
and displays a dialog box for you to select a new Graphics Exchange file to read.  Once 
you select a file name from the dialog box and click OK to dismiss the dialog, the data 
are read and displayed.  The labels for each set of data read appear in the Utexas menu so 
that you can select which set of data is the "Current Data Set".  If no labels were entered 
in the data for UTEXAS4, the first line of the problem heading is used to identify each 
problem set.  The items displayed initially are controlled by the default selections in the 
Application Preferences. 

Open… 

The Open menu is similar to the New menu except that any data that have been 
previously read into memory are saved and remain in memory.  The new data are added 
to the existing data and the Utexas menu reflects the changes. 
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Print… 

The Print menu is used to print the graphics displayed on the screen.  When you 
choose this menu a standard Windows print dialog box is displayed for you to choose the 
printer and number of copies to be printed.  You can also print by clicking on the Print 
icon in the Main Toolbar. 

Print Preview 

Print Preview is used to view what will be printed before it is printed.  If you are 
satisfied with the display you can click the Print button located near the upper left of the 
print preview window or you can dismiss the print preview dialog box by clicking the 
Close button to print later. 

Print Setup 

The Print Setup item displays a standard Windows print setup dialog box for you 
to choose a printer and paper. 

Default Input File Directory … 

This menu item is used to set the default directory for opening Graphics Exchange 
Files.  The first time you choose File->New or File->Open, the default directory is the 
one designated in the Application Preferences.  The Default Input File Directory menu 
item is used to change the default directory.  When you choose this menu item, a dialog 
box is displayed for you to choose the directory path where Graphics Exchange Files are 
located.  Ordinarily when you change the default directory you will want to choose either 
the File->Save Preferences or File->Save Preferences to File menu items to save the 
selection. 

The default input file directory only applies to the first time you open a file after 
starting  TexGraf4.  After a file has been opened, the default directory for opening files is 
assumed to be the last directory in which files were opened. 

Create DXF File 

Create DXF File creates a file of graphics information using the Autodesk®, Inc. 
"Drawing Exchange File" (DXF) format.  This option and the file that is created are used 
to import UTEXAS4/TexGraf4 graphics information into a CAD program that recognizes 
the DXF file format.  The file contains the information needed to display the items 
currently displayed in TexGraf4's main display window.  You choose what is contained 
in the DXF file by choosing what is displayed in TexGraf4's display window.  Use the 
Display->Selections menu to choose what will be displayed and contained in the DXF 
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file.  Additional information regarding DXF files is given in Section 9 - DXF FILE 
EXPORT. 

Save Preferences 

This menu item is used to save the current settings as the default Application 
Preferences.  These are the default settings that are used when the application starts up.  
Almost all settings are "global" for all data sets and do not depend on any particular set 
of data.  However, the display settings that are saved as preferences do depend on 
whether data exist and which set of data is current.  If no data exist, the display settings 
that are saved are the settings that are currently used as defaults by TexGraf4 when new 
sets of data are read.  These settings are controlled by the last Application Preferences 
that were read and by any changes that were made using the Display->Selections menu 
when no data existed in memory.  If data do exist in memory when the Application 
Preferences are saved, the display settings will be the ones that have been chosen for the 
Current Data Set.  Thus, in saving Application Preferences it is important to have the 
appropriate data (or no data) active at the time the Application Preferences are saved. 

Restore Preferences 

Resets the preferences to the default Application Preferences.  If data have been 
read from a Graphics Exchange File and exist in memory when you choose this menu 
item, you will be prompted to choose whether to set the current display selections  to the 
default display selections read from the new Application Preferences or leave the display 
selections as they are.  All other settings (colors, line styles, etc.) automatically take 
effect when new Application Preferences are read regardless of whether data exist or not. 

Save Preferences to File… 

Saves the current settings to a file rather than to the standard Application 
Preferences.  When you choose this menu item you will be prompted for the name of the 
file in which the settings are to be saved.  You can actually create multiple sets of 
preferences by saving different setting to different files.  The information saved follows 
the same rules described above for the Save Preferences item.  That is, the selections for 
what information is displayed may either be the current default settings or the settings for 
the Current Data Set depending on what, if any data exist in memory. 

Once saved the settings can be read back in using the File->Read Preferences 
from File menu item. 

Read Preferences from File… 

Similar to the Restore Preferences menu item except you are prompted for the 
name of a file containing the preferences. When you choose the Read Preferences from 
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File menu item a standard Windows file open dialog is displayed for you to choose the 
Preferences file to read.  Once you select the file and dismiss the dialog box by clicking 
the OK button, the new Preferences file is read and the new settings take affect.  You 
must have already created a preferences file using the File->Save Preferences to File 
menu item to use the Read Preferences from File menu item. 

The primary Application Preferences contain the default settings that are active at 
startup.  If you want to use a set of preferences different from the default preferences, you 
can choose the desired settings in TexGraf4 and then use the File->Save Preferences to 
File menu to create an alternate Preferences file.  This File->Read Preferences from 
File menu item is then used to read the preferences from the file that you created and 
make them the current application settings.  In this way you can actually create and use 
several different sets of preferences. 

Most Recent Files 

Immediately following the Read Preferences from File menu item in the File 
menu is a list of the six most recently opened files.  You can choose any of the six most 
recently opened files from this list to open them. 

Exit 

Use Exit to quit TexGraf4 when you are finished. 
 
 

 



  12   

 

Edit Menu 

The Edit menu has just one item.  Normally, when nothing is selected the item is 
labeled "Move" and is dimmed.  If you select either an item associated with the material 
property table (interior lines, border lines or text) or the text representing the factor of 
safety, the text for the item in the Edit menu changes.  Depending on which of these 
items is selected the text will then read either "Move Material Property Table" or 
"Move Factor of Safety Text".  This menu is used to move these items on the display 
screen using the mouse or other pointing device.  Refer to Section 7 for further details on 
moving items. 
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Display Menu 

The Display menu is used to select what is displayed.  The menu has six (6) items 
which are each described below. 

Selections… 

The Selections item is used to choose what is displayed for the “current” data set.  
When you choose this item a tabbed dialog box is displayed for you to make your 
selections.  The display selections are grouped into four categories (four tabs): (1) Stage 
1 Input, (2) Stage 2 Input, (3) Results, and (4) Miscellaneous. Each of these categories is 
briefly described below and the contents are summarized in Tables 3.1 through 3.4.  
More detailed information on specific items displayed is presented in Section 5 - 
GRAPHICAL DISPLAY OF ITEMS. 

Stage 1 Input 

Stage 1 Input includes data that are input to UTEXAS4 for conventional, single-
stage computations and for the first stage of multi-stage computations.  The Stage 1 Input 
items that can be selected for display are listed in Table 3.1.  The "page" (tab) of the 
Display Selections dialog box containing the Stage 1 Input selections is shown in Figure 
3.1; this page contains two buttons: Select All and Clear All.  Use the buttons to select 
all of the Stage 1 Input items for display or to clear (“de-select”) all Stage 1 Input items 
from the display list. 

Stage 2 Input 

Stage 2 Input selections consist of the input data used for the second and third 
stages of multi-stage computations.  These data only exist when multi-stage computations 
are performed. Stage 2 Input items that can be displayed are listed in Table 3.2. The 
"page" (tab) of the Display Selections dialog box containing the Stage 2 Input selections 
is shown in Figure 3.2.  This dialog page contains Select All and Clear All buttons that 
can be used to select or clear ("de-select") all Stage 2 input items from the display list. 
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Table 3.1 

Stage 1 Input Data Items that Can be Displayed Graphically 

Item Description 
Profile Lines Lines are drawn representing the Profile Lines 
Profile points Symbols are plotted at each point where a coordinate was 

specified for the Profile Line. 
Profile line numbers The number of each Profile Line is displayed as text 

superimposed on the Profile Line.  The text is located at the 
midpoint of the longest visible segment of each Profile Line. 

Fill profile/material 
regions 

The area beneath each Profile Line is filled with a pattern. 

Material numbers The numbers of materials are displayed in the area beneath each 
Profile Line. 

Material property 
table 

A table of material properties is displayed.  The table contains 
the material number, material description, unit weight, shear 
strength parameters and pore water pressure information. 

Piezometric lines Lines are drawn representing each piezometric line. 
Piezometric line 
points 

Symbols are plotted at each point where coordinates were 
specified to define the piezometric line. 

Piezometric line 
numbers 

The number of each piezometric line is displayed as text on the 
line.  The numbers are displayed on the longest visible segment 
of each piezometric line. 

Interpolation points 
for pore pressures 

Symbols are displayed at the location of each point that was 
entered for interpolating values of pore water pressure. 

Interpolation points 
with r-sub-u values. 

Symbols are displayed at the location of each point where values 
of the pore pressure coefficient, ru, were specified for 
interpolating pore water pressures. 

Interpolation points 
for shear strengths. 

Symbols are displayed at the location of each point where values 
of shear strengths are specified for interpolation. 

Slope line. The line representing the surface profile of the slope is 
displayed. 

Slope points. Symbols are plotted at the location of each point on the slope 
entered as input data (or generated by UTEXAS4 from the 
Profile Lines). 

Distributed loads - 
Normal 
(perpendicular) 

The normal (perpendicular) component of the distributed load is 
displayed as a series of vectors acting on the surface of the slope.

Distributed loads - 
Shear (tangential) 

The shear component of the distributed load is displayed. 

Distributed load 
points. 

Symbols are displayed at each point where the distributed load 
was specified in the input data. 

Line loads. Scaled vectors representing each line load are displayed. 
Reinforcement lines. Each reinforcement line is drawn. 
Reinforcement 
points. 

Symbols are plotted at each location where a coordinate and 
forces were specified for reinforcement lines. 
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Table 3.1 - continued 

Stage 1 Input Data Items that Can be Displayed Graphically 

Item Description 
Longitudinal 
reinforcement force 
distribution. 

The distribution of longitudinal forces in the reinforcement is 
displayed immediately adjacent to the reinforcement line. 

Transverse 
reinforcement force 
distribution. 

The distribution of transverse (shear) forces in the reinforcement 
is displayed immediately adjacent to each reinforcement line. 

Initial circle center 
points. 

A cross (+) representing the center point of the initial trial circle 
is displayed and lines are drawn from the center of the circle to 
the two end points of the circle.  If an individual circle was 
analyzed, rather than a search, the individual circle is displayed.  
Not applicable to noncircular shear surfaces. 

Initial (or individual) 
shear surface lines. 

A line representing either the initial circular arc or the initial trial 
noncircular shear surface is displayed.  If an individual shear 
surface is analyzed, rather than a search, the individual shear 
surface is displayed. 

Initial (or individual) 
shear surface points. 

Symbols are displayed at each location where a coordinate was 
specified to define the initial trial noncircular shear surface, or, if 
an individual shear surface was analyzed, at each point used to 
define the individual shear surface.  Not applicable to circular 
shear surfaces. 

Specified search grid. The grid used to search for a critical center with circles is 
displayed.  See Section 5 for more information on what is 
displayed. 

Crack information. Information pertaining to any "tension" crack is displayed; a 
broken line is displayed at the base of the "cracked" zone and the 
cracked zone is filled with vertical hatching.  (The original 
default color for this hatching is red to distinguish this from the 
hatching for the water - see below.) 

Crack water (or other 
fluid) information. 

Water in the tension crack is displayed by vertical hatching. (The 
original default color for this hatching is blue to distinguish this 
from the hatching for the crack itself - see above.) 
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Figure 3.1 - Dialog Box "Page" (Tab) Used to Select Stage 1 Input Data for Display 

 



  17   

Table 3.2 

Stage 2 Input Data Items that Can be Displayed Graphically 

Item Description 
Material property 
table 

A table of material properties for the second and third stage of 
multi-stage computations is displayed.  The table is identical to 
the one displayed with the material properties for the first stage 
except for the actual values in the table. 

Piezometric lines Lines are drawn representing each piezometric line defined for 
the second- and third- stage computations. 

Piezometric line 
points 

Symbols are plotted at each point where coordinates were 
specified to define the piezometric line for the second- and third- 
stage computations. 

Piezometric line 
numbers 

The number of each piezometric line is displayed as text on the 
line.  The numbers are displayed on the longest visible segment 
of each piezometric line for the second- and third- stage 
computations. 

Interpolation points 
for pore pressures 

Symbols are displayed at the location of each point for 
interpolating values of pore water pressure for the second- and 
third- stage computations. 

Interpolation points 
with r-sub-u values. 

Symbols are displayed at each point where values of the pore 
pressure coefficient, ru, were specified for interpolation for the 
second- and third- stage computations. 

Interpolation points 
for shear strengths. 

Symbols are displayed at the location of each point where values 
of shear strength were specified for interpolation for the second- 
and third- stage computations. 

Distributed loads - 
Normal 
(perpendicular) 

The normal component of the distributed load for the second- 
and third- stage computations is displayed as a series of vectors 
acting on the surface of the slope. 

Distributed loads - 
Shear (tangential) 

The shear component of the distributed load for the second- and 
third- stage computations is displayed. 

Distributed load 
points. 

Symbols are displayed at each location where a value of 
distributed load was specified in the input data for the second- 
and third- stage computations. 

Line loads. Scaled vectors representing each line load for the second- and 
third- stage computations are displayed. 
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Figure 3.2 - Dialog Box "Page" (Tab) Used to Select Stage 2 Input Data for Display 
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Results 

The Results items consist of information created as part of the slope stability 
computations.  These items are only available for display when slope stability 
computations are successful.  In contrast the Stage 1 and Stage 2 Input items described 
above are available even when no computations are requested4 or when computations are 
not successful in UTEXAS4.  The Results items that can be displayed are listed in Table 
3.3.   

The "page" (tab) of the Display Selections dialog box containing the Results 
selections is shown in Figure 3.3; this page contains two buttons: Select All and Clear 
All.  Use the buttons to select all of the Results items for display or to clear (“de-select”) 
all Results items from the display list. 

Miscellaneous 

Miscellaneous items include the triangles created for the interpolation of pore 
water pressures or shear strength, and the x-y coordinate axes.  The Miscellaneous items 
are listed in Table 3.4. The "page" (tab) of the Display Selections dialog box containing 
the Miscellaneoues selections is shown in Figure 3.4. 

The last three items listed in Table 3.4 are "special" items.  The "special" items 
are used to display setting information (available patterns, line styles, and symbols) for 
TexGraf4 and have nothing to do with displaying a particular set of data from 
UTEXAS4. The "special" items are displayed as an aid to setting up TexGraf4 and 
setting information on how items are to be displayed.  When any of the special items is 
selected for display, none of the other items in Table 3.4 or Tables 3.1 through 3.3 are 
displayed.. 

Clear Display for Selection 

This menu item is used to to suppress display of an item that is currently selected 
in the main display window.  Choosing this item has the same effect as choosing the 
Display->Selections menu item and unchecking the corresponding check box in the 
tabbed Display Selections dialog box.  Clear Display for Selection only applies to the 
current data set and the type of item that you have selected.  To re-display any item that 
you have chosen not to display, you must choose the Display->Selections menu item and 
again check the appropriate item in the dialog box that is displayed. 

                                                 
4 UTEXAS4 may be requested to read data, but perform no computations.  This is done by entering the 
“NO compute” Command Word in the UTEXAS4 input data. 
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Table 3.3 

Results of Stability Computations that Can be Displayed Graphically 

Item Description 
Computed factor of 
safety 

Text is displayed showing the computed factor of safety and, if 
Spencer's procedure is used, the computed side force inclination. 

Critical (or 
individual) shear 
surface line 
segments. 

The line representing the most critical shear surface (lowest 
factor of safety) found by the automatic search is displayed. If an 
individual shear surface is analyzed, rather than a search, the 
individual shear surface is displayed.  

Critical (or 
individual) shear 
surface points. 

The points along the most critical shear surface (lowest factor of 
safety) found by the automatic search are displayed. If an 
individual shear surface is analyzed, rather than a search, points 
on the individual shear surface are displayed.  The points 
correspond to the locations of the vertical boundaries between 
slices. 

Critical (or 
individual) circle 
center point. 

A cross (+) is displayed at the center of the critical circle, or if an 
individual circle was analyzed the center of the individual circle.  
Straight lines are also drawn from the center point to the two 
ends of the circle.  Not applicable to noncircular shear surfaces. 

Factor of safety 
contours (circles - 
fixed grid only) 

Displays contours of factor of safety based on various trial center 
points for circles.  This is available only when a search has been 
conducted using circles and the Type 2, "fixed-grid" search 
option. 

"N-most" critical 
shear surfaces 

Draws lines representing the n-most shear surfaces with the 
lowest factors of safety located during an automatic search.  The 
input data to UTEXAS4 designates the number (n) of shear 
surfaces that are to be saved for this display. 

Slices Draws vertical lines representing the boundaries between slices 
Force vector for 
water in crack. 

Displays a horizontal vector representing the force due to water 
in the vertical "tension" crack.  The force is displayed for the 
most critical shear surface found in an automatic search or for 
the individual shear surface if an individual surface is analyzed. 

Total normal stress 
on shear surface 

Displays the distribution of total normal stresses along the shear 
surface.  The shear surface for this distribution and the following 
two distributions is the most critical shear surface or, in the case 
of no search, the individual shear surface that is specified. 

Effective normal 
stresses on shear 
surface 

The distribution of effective stresses along the shear surface is 
displayed - only meaningful for effective stress analyses where 
pore water pressures are specified. 

Pore pressures on 
shear surface 

The distribution of pore water pressures along the shear surface 
is displayed. 

Line of thrust A line through the point of action of the resultant side forces 
between slices ("line of thrust") is displayed; only applicable to 
Spencer's procedure of analysis. 
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Figure 3.3 - Dialog Box "Page" (Tab) Used to Select Results for Display 
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Table 3.4 

Miscellaneous Items that Can be Displayed Graphically 

Item Description 
XY Axes Displays the x-y coordinate axes for the slope geometry. 
Triangulation of pore 
pressure interpolation 
points - Stage 1 

Displays triangles created for the interpolation data points.  
Triangles are for the first-stage (conventional) data where 
pressure values were specified for pore water pressures. 

Triangulation of  
r-sub-u interpolation 
points - Stage 1 

Same as above except data for ru values. 

Triangulation of  
shear strength 
interpolation points - 
Stage 1 

Same as above except for data for interpolating shear strengths. 

Triangulation of pore 
pressure interpolation 
points - Stage 2 

Same as above except for pressure values, Stage 2 input. 

Triangulation of  
r-sub-u interpolation 
points - Stage 2 

Same as above except for ru values, Stage 2 input. 

Triangulation of  
shear strength 
interpolation points - 
Stage 2 

Same as above except for values used to interpolate shear 
strengths, Stage 2 input 

Print area rectangle Displays a rectangle representing the actual size of the area 
where the geometry will be displayed on the printed page 
(Subject to limitations described in Section 5 - GRAPHICAL 
DISPLAY OF ITEMS) 

Available patterns Displays the available patterns that can be selected for filling the 
areas beneath Profile Lines. 

Available line styles Displays the available line styles that can be assigned for 
drawing lines (e. g. Profile Lines, Piezometric Lines, etc.) 

Available symbols Displays the various symbols that can be used to display points. 
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Figure 3.4 - Dialog Box "Page" (Tab) Used to Select Miscellaneous Items for Display 
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Set All for Current Data Set 

This sets all items for the Current Data Set so that they will be displayed.  
Choosing this menu item is equivalent to choosing the Display->Selections menu item 
and checking all the items in the tabbed dialog box that is displayed. 

Clear All for Current Data Set 

This changes the settings so that nothing is displayed for the Current Data Set.  It 
is equivalent to choosing the Display->Selections menu item and clearing all the check 
boxes in the tabbed dialog box that is displayed.  If only a few items are to be displayed, 
it may be easiest to first clear all items for display by choosing this menu item (Clear All 
for Active Data Set) and then using the Display->Selections menu item to select the few 
items that are to be displayed. 

Set All for All Data Sets 

Similar to Set All for Current Data Set described above except applies to all the 
data sets that have been read into TexGraf4.  The maximum amount of information is 
displayed by choosing this item. 

Clear All for All Data Sets 

Similar to Clear All for Current Data Set described above except clears display 
of information for all the data sets that have been read into TexGraf4. 
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Settings Menu 

The Settings menu is used to control how information is displayed.  Many of the 
Settings menu items apply to what is currently selected in the main display window and 
require that an appropriate item be selected before choosing the Settings menu item.  For 
example the Settings->Line Weight item is used to set line weights.  To set the line 
weight used to display Profile Lines you should first select a segment on one of the 
Profile Lines and then choose an appropriate line weight from the Settings->Line 
Weight menu.  Each of the Settings menu items is described below. 

Line Weight 

The Line Weight menu item is used to set the weight of lines drawn in the 
display.  To set the line weight for a particular item, first select the item by clicking on it 
in the display window and then choose a line weight using the Line Weight menu.  Line 
weights are assigned based on the type of object, rather than on a specific instance of the 
object.  For example, all Profile Lines have the same line weight; when you change the 
line weight for one Profile Line, the line weight is changed for all Profile Lines.  The 
items for which you can change   line weight are listed in Table 3.5.  Table 3.5 also gives 
further details on the items that must be selected to change the corresponding line weight.  
For further details on selecting items see Section 6 - SELECTING ITEMS and Table 6.1. 

The Line Weight menu has a sub-menu listing the available line weights.  The 
first 8 items in the sub-menu are TexGraf4’s “standard” line weights; the standard line 
weights are always available.  The last item in the Line Weight sub-menu allows you to 
select “Custom” line weights.  Depending on the settings in the Graphics Configuration 
File there may be additional “supplemental” line weights available listed after the first 8 
standard line weights and before the custom line weight option.  The line weights are 
described in additional detail below. 

Standard Line Weights. 

The standard line weights are “Hairline” and 1, 2, 3, 4, 5, 7 and 10 “points”.  One 
“point” is approximately 1/72-inch.  “Hairline” is the finest line weight that the output 
device can produce.  Normally this will differ depending on the output device; printers 
and graphics monitors typically have different line widths.  
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Table 3.5 

Items that May Have Their Line Weights Changed 

Item Selection/Explanation 
Material property 
table 

Select a “grid” line in the table of material properties to set the 
line weight.  Separate line weights may be set for the border 
(exterior lines) and for interior lines in the table.  Select an 
appropriate interior or border line to set the corresponding line 
weight. 

Profile lines Select a Profile Line segment to set the line weight for drawing 
Profile Lines. 

Profile line point Select a point on the Profile Line to set the line weight for 
drawing symbols at the Profile Line coordinate points. 

Piezometric lines Select a piezometric line to set the line weight for drawing 
piezometric lines. 

Piezometric line 
points 

Select a point on the piezometric line to set the line weight for 
drawing symbols at the piezometric line coordinate points. 

Pressure,  or shear 
strength 
interpolation point 

ru Select one of the interpolation data points to set the line weight 
for drawing symbols at the points. 

Pressure,  or shear 
strength 
interpolation triangle 

ru Select one of the triangles in the triangulation of interpolation 
data points to set the line weight for drawing the triangles. 

Slope line Select a segment of the slope line. 
Slope points Select a slope point to set the line weight for drawing the 

symbols at slope coordinate points. 
“Crack” line. Select a point or segment of the line representing the bottom of 

the crack. 
“Crack” water line. Select a segment of the line representing the water surface for 

the crack. 
Distributed load 
point 

Select a distributed load point t set the line weight for drawing 
symbols at the points where values of the distributed load are 
specified. 

Distributed load 
distribution 

Select the outline of the distributed load to set the line weight for 
drawing the vectors and outline of the distributed load. 

Line load  vector Select either a line load point or vector to set the line weight for 
drawing the line load vectors. 

Reinforcement point Select a reinforcement line point to set the line weight for 
drawing symbols at points where the reinforcement line and 
forces are specified. 

Reinforcement line 
segment 

Select a reinforcement line segment  to set the line weight for 
drawing reinforcement lines. 

Reinforcement force 
distribution. 

Select the longitudinal or transverse reinforcement force 
distribution to set the line weight for drawing the force 
distribution (outline and vectors). 

<continued on next page> 
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Table 3.5 - continued 

Items that May Have Their Line Weights Changed 

Item Selection/Explanation 
Initial trial shear 
surface point. 

Select a point on the initial trial shear surface to set the line 
weight used to draw symbols. (Applicable to noncircular shear 
surfaces only). 

Initial trial shear 
surface line. 

Select either the arc or line segment representing the initial trial 
shear surface to set the line weight for drawing the surface. 

Initial trial circle 
center. 

Select the center point for the initial trial circle to set the line 
weight for drawing the center point and radii extending from the 
center point to each end of the initial trial circle.  (Applicable to 
circular shear surfaces only). 

Search grid. Select the grid used for searching to set the line weight used to 
draw the grid. (Applicable to circular shear surfaces only). 

Critical shear surface 
point. 

Select one of the points along the critical shear surface to set the 
line weight for drawing symbols; symbols (points) coincide with 
the boundaries between slices. 

Critical trial shear 
surface line. 

Select a segment of the critical shear surface; “segments” 
correspond to the base of slices. 

Critical circle center. Select the center point for the critical circle to set the line weight 
used to draw the center and radii extending from the center point 
to each end of the critical circle.  (Applicable to circular shear 
surfaces only). 

N-Most Critical 
Shear Surfaces 

Select one of the “n-most” critical shear surfaces to set the line 
weight for drawing the n-most critical shear surfaces.  All “n” 
surfaces have the same line weight. 

Total normal stress, 
effective normal 
stress and pore water 
pressure distribution.  

Select the appropriate stress distribution to set the line weight 
for drawing the respective distribution of stress along the shear 
surface. 

Vertical slice 
boundaries 

Select either a slice or one of the vertical lines between slices to 
set the line weight for drawing the vertical boundaries between 
slices. 

Crack water force 
vector 

Select the vector representing the force due to water in the 
“tension” crack to set the line weight for drawing the force 
vector. 

Line of thrust Select the line of thrust to set the line weight for drawing it. 
Factor of safety 
contours 

Select the factor of safety contours to set the line weight for 
drawing the contours. 

X-Y coordinate axes Select either the horizontal (x) or vertical (y) axis to set the line 
weight for drawing the axes and tick marks.  The same line 
weight is used to draw both axes 
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Supplemental Line Weights. 

Supplemental line weights listed in the Line Weight sub-menu depend on 
information in the Graphics Configuration File.  The information in the Graphics 
Configuration File designates what supplemental line weights are available and how they 
are defined:  Supplemental line weights may be defined in units of points, inches or 
millimeters or a mix of these three units. 

Custom… 

The Custom line weight menu item allows you to designate the line weight in 
either points, inches or millimeters.  When you choose Custom line weights a dialog box 
is displayed for you to enter the line weight. 

Line Style 

The line Style menu item is used to set the style (solid, dashed, broken, etc.) for 
drawing lines for various items.  TexGraf4 provides for solid lines and twelve (12) styles 
of broken and dashed lines.  The available line styles are shown in Figure 3.5. 

 

 
Figure 3.5 - Available styles for drawing lines. 

You can also display available line styles on the screen.  To do so choose the 
Display->Selections menu item and then check “Available Line Styles” in the dialog box 
for display selections (Available Line Styles is under the Miscellaneous tab in the 
Display Selections dialog box).  The Available Line Styles item is one of the "special" 
Miscellaneous Display items; when chosen for display only line styles and other selected 
"special" items (available patterns, colors and symbols) are displayed. 
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Line styles are applied to items in the same way that line weights are set:  An item 
is first selected in the main display window and the appropriate line style is then chosen 
from the Settings->Line Style menu.  The items for which line styles can be set are listed 
in Table 3.6. 

Point Size 

The point size menu is used to set the size of symbols drawn to represent various 
points, including points on the Profile Lines, points used to interpolate pore water 
pressures, center points for the initial trial circle, etc.  TexGraf4 provides 5 standard point 
sizes plus a number of optional point sizes depending on the information in the Graphics 
Configuration File.  The standard point sizes are in “points” (1 point = 1/72 inch).  
Optional point sizes may be designated in points, inches or millimeters and are set by 
information in the Graphics Configuration File. 

The Settings->Point Size menu item has a sub-menu for selecting the specific 
point size to be used.  To set the size of a given type of point (e. g. Profile Line points), 
first select the point and then choose the desired point size from the Settings->Point Size 
sub-menu. The items for which point sizes can be set are listed in Table 3.7.  The 
required selections for setting point sizes are also described in Table 3.7. 

Point (Symbol) Type 

The Point Type menu is used to set the type of symbol drawn to represent various 
points, e. g. points on the Profile Lines, points used to interpolate pore water pressures, 
etc..  TexGraf4 provides the 21 different symbols shown in Figure 3.6. 

 

Figure 3.6 - Symbols Available for Displaying Points in TexGraf4 

You can display the list of available symbols on the screen.  To do so choose the 
Display->Selections menu item and then check “Available Symbols” in the dialog box 
for display selections (Available Symbols is under the Miscellaneous tab in the Display 
Selections dialog box). The Available Symbols item is one of the "special" Miscellaneous 
Display items; when chosen for display only symbols and other selected "special" items 
(available line styles and patterns) are displayed. 
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Table 3.6 

Items that May Have The Line Style Changed 

Item Selection/Explanation 
Profile lines Select either a point or a segment of a Profile Line to set the line 

style for drawing Profile Lines.  (Profile Line points are always 
drawn using the solid line style for drawing the symbol.) 

Piezometric lines 
segments 

Select either a point or a segment of a piezometric line to set the 
line style for drawing piezometric lines. ( Piezometric line points 
are always drawn using the solid line style for drawing the 
symbol.) 

Pressure,  or shear 
strength 
interpolation triangle 

ru Select one of the data points or one of the triangles in the 
triangulation of interpolation data points to set the line style for 
drawing the triangles.  Note:  You can select points as well as 
triangles to set the triangle line style; the line style for drawing 
the points (symbols) is always solid. 

Slope line Select either a point or a segment of the slope line to set the line 
style for drawing the slope surface profile. Slope points 
(symbols) are always drawn using the solid line style. 

“Crack” line. Select a point or segment of the line representing the bottom of 
the crack to set the line style for drawing the crack bottom. 

“Crack” water 
surface line segment 

Select a segment of the line representing the water surface in the 
crack to set the line style for drawing the water surface. 

Reinforcement lines Select one of the following to set the line style for drawing 
reinforcement lines: (1) a reinforcement line point, (2) a 
reinforcement line segment, (3) a longitudinal reinforcement 
force distribution, or (4) transverse reinforcement force 
distribution.  Note: Reinforcement points (symbols) and the 
outline of the force distributions are always drawn using a solid 
line style. 

Initial trial shear 
surface. 

Select either a point or segment of the initial trial circular or 
noncircular shear surface to set the line style for drawing the 
shear surface. 

Critical shear 
surface. 

Select either a point or segment of the critical circular or 
noncircular shear surface to set the line style for drawing the 
shear surface. 

Slice boundaries Select either a slice or a vertical slice boundary between slices to 
set the line style for drawing the vertical slice boundaries. 

Line of thrust Select the line of thrust to set the line style for drawing it. 
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Table 3.7 

Items that May Have The Point Sizes Changed 

Item Selection/Explanation 
Profile line points Select either a point on a Profile Line or a segment of the Profile 

Line to set the symbol size. 
Piezometric line 
points 

Select either a point on a piezometric line or a segment of the 
piezometric line to set the symbol size. Symbol sizes for each 
loading stage (1 & 2) are set independently; therefore, you 
should select a point for the stage for which you want to set the 
point size. 

Pressure,  or shear 
strength 
interpolation point 

ru Select one of the interpolation data points (symbols) to set the 
size.  Pressure,  and shear strength values each have different 
symbol sizes that are set independently.  Select the appropriate 
type of interpolation data point (e. g. u  values) to set the 
corresponding symbol size. Symbol size for each loading stage 
(1 & 2) are also set independently; therefore, you should select a 
point for the stage for which you want to set the point size. 

ru

r

Slope points Select either a point on the slope line or a segment of the line 
defining the slope profile to set the symbol size. 

Distributed load 
point 

Select either a distributed load point or the outline of one of the 
load distributions (normal stress, shear stress) to set the size of 
the symbols drawn at points where the distributed load is 
specified.  Point size for each loading stage (1 & 2) are set 
independently; select a point for the stage where the point size is 
to be set. 

Reinforcement point Select either a point on the reinforcement line or the outline of 
the distribution of longitudinal or transverse force in the 
reinforcement to set the symbol size for reinforcement points. 

Initial trial circle 
center 

Select the center point of the initial trial circle to set the size of 
the symbol drawn at the center point.  (Applicable to circular 
shear surfaces only.) 

Initial shear surface 
coordinate points. 

Select either a point or line segment on the initial trial shear 
surface to set the size of symbols drawn at the locations where 
coordinates are specified for the initial trial shear surface.  
(Applicable to noncircular shear surfaces only.) 

Critical shear surface 
coordinates points 

Select either a point or line segment on the critical shear surface 
to set the symbol size.  Symbols are drawn at points 
corresponding to the vertical boundaries between slices. 

 

 



  32   

The appearance of symbols on the screen depends on the line weight that is 
chosen.  Line weights for symbols are generally set by first selecting a point and then 
using the Settings->Line Weight menu item to choose the line weight.  All of the 
symbols that are shown in Figure 3.6 and are displayed on the screen when you choose to 
display the list of available symbols are drawn using a line weight of 1 point. 

The items for which symbol types can be set are presented in Table 3.8.  To set 
the symbol for a particular type of data first select a point and then choose the desired 
symbol in the Settings->Point (Symbol) Type menu item.  This menu item has a sub-
menu with the various symbols displayed for you to choose from.  The required 
selections for setting symbols are described in Table 3.8. 

Default symbols for the various items listed in Table 3.8 are stored with the 
Application Preferences.  If you want to use different symbols from the default ones, you 
can change the symbols using the Settings->Point (Symbol) Type menu item and save 
the new settings as preferences. 

Font 

The Font menu is used to set the font for displaying the items listed in Table 3.9.  
To set the font for a particular item first select the item and then choose the 
Settings->Font menu.  A standard font dialog box is then displayed for you to set the 
appropriate font information.  The selections that must be made for setting font 
information are described in Table 3.9.  Default font selections are stored in the 
Application Preferences. 

Color 

Use the Color menu to set the color for drawing the items listed in Table 3.10.  To 
set the color for a particular item first select the item and then choose the 
Settings->Color menu.  A standard color dialog box is then displayed for you to set the 
appropriate color.  The selections that must be made for setting colors are described in 
Table 3.10. 

Patterns 

The Patterns menu is used to set patterns for filling the various regions listed in 
Table 3.11.  To set the pattern for filling a particular item first select the item and then 
choose the Settings->Patterns menu.  The Patterns menu item has a sub-menu listing 
the patterns that can be set.  The specific patterns that are shown in the menu are 
determined by information in the Graphics Configuration File. TexGraf4 has a total of 38 
different patterns that can be used.  Some or all of the available patterns may be shown in 
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Table 3.8 

Items that May Have the Type of Symbol (Point) Changed 

Item Selection/Explanation 
Profile line points Select either a point on a Profile Line or a segment of the line to 

set the symbol type. 
Piezometric line 
points 

Select either a point on a piezometric line or a segment of the 
line to set the symbol type. Symbol types are set independently 
for each loading stage (1 & 2); therefore, you should select a 
point for the appropriate stage to be changed. 

Pressure,  or shear 
strength 
interpolation points 

ru Select either one of the interpolation data points (symbols) or a 
triangle in the triangulation of points to set the symbol type.  
Pressure, u  and shear strength values each have different 
symbols that are set independently. Symbol types are also set 
independently for each loading stage (1 & 2); therefore, you 
should select a point for the appropriate stage to be changed. 

r

Slope points Select either a point on the slope line or a segment of the slope 
line to set the symbol type for slope points. 

Distributed load 
points 

Select either a distributed load point or the outline of one of the 
load distributions (normal stress, shear stress) to set the symbols 
drawn at points where the distributed load is specified.  Point 
size for each loading stage (1 & 2) are set independently; select a 
point for the stage where the point size is to be set. 

Reinforcement 
points 

Select either a point on the reinforcement line or the outline of 
the distribution of either longitudinal or transverse force in the 
reinforcement to set the symbol type. 

Initial shear surface 
coordinate points 

Select either a point or line segment on the initial trial shear 
surface to set the symbol type.  (Applicable to noncircular shear 
surfaces only; no points are drawn for initial trail circles.) 

Critical shear surface 
coordinates points 

Select either a point or segment of the critical shear surface to 
set the symbol type used to draw points. 
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Table 3.9 

Items with Font Information 

Item Selection/Explanation 
Profile line numbers Select either a point, line segment or line number for one of the 

Profile Lines to set the font for Profile Line numbers. 
Material numbers Select the material number or region of material beneath any 

Profile Line to set the font for displaying material numbers. 
Piezometric line 
numbers 

Select either a point, line segment or line number of one of the 
piezometric lines to set the font for drawing piezometric line 
numbers. 

Material property 
table 

Select either the text or an interior or exterior border line in the 
table of material properties to set the font for drawing the table. 

Factor of safety Select the text for the factor of safety (and side force inclination 
if Spencer’s procedure was used) to set the font. 

Factor of safety 
contours 

Select the factor of safety contours to set the font for labeling 
contours (drawing contour values). 

Coordinate axis 
labels 

Select either the horizontal or vertical coordinate axis to set the 
font for labeling the axes.  The same font is used for both axes; 
setting the font for one axis affects both. 
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Table 3.10 

Items Whose Color Can be Set 

Item Selection/Explanation 
Coordinate axis and 
text 

Select either the horizontal or vertical axis to set the color for the 
text and lines.  The text and lines on both axes use the same 
color. 

Crack “water” force. Select the force vector representing the water in the crack to set 
the color for the vector. 

“Crack” line. Select either a segment of the line defining the crack bottom line 
or a point on the crack bottom line to set the color. 

Critical circle center. Select the center of the critical circle to set the color for the 
center point and radii extending from the center to each end of 
the shear surface. 

Critical shear surface 
point. 

Select a point on the critical (circular or noncircular) shear 
surface to set the point color. 

Critical trial shear 
surface line. 

Select a line segment on the critical (circular or noncircular) 
shear surface to set the line color. 

Distributed load 
point 

Select a distributed load point to set the color of the points.  
(Separate color assignments are made for Stage 1 and 2.) 

Distributed load 
normal distribution 

Select a portion of the distributed normal stress to set the color 
of the outline and fill of the normal stress distribution.  (Separate 
color assignments are made for Stage 1 and 2.) 

Distributed load 
shear distribution 

Select a portion of the distributed shear stress to set the color of 
the outline and fill of the shear stress distribution.  (Separate 
color assignments are made for Stage 1 and 2.) 

Factor of safety Select the text representing the computed factor of safety (and 
side force inclination, if applicable) to set the text color. 

Factor of safety 
contours 

Select the factor of safety contours to set the color of the contour 
lines and text.  Contour lines and text are the same color. 

Factor of safety 
triangles. 

Select one of the triangles in the triangulation of grid points to 
set the color for drawing the triangles.  These are the triangles 
used to contour factors of safety 

Grid for search Select the search grid to set the grid color. 
Initial 
trial/individual circle 
center. 

Select the center of the individual or initial trial circle to set the 
color for the center point and radii extending from the center to 
each end of the shear surface. 

Initial trial shear 
surface point. 

Select a point on the initial trial noncircular shear surface to set 
the color of the points. 

Initial trial shear 
surface line. 

Select the individual or initial trial circular or noncircular shear 
surface line to set the line color. 

Line load. Select either the tip or tail point of the line load vector to set its 
color. (Separate color assignments are made for Stage 1 and 2.) 

Line of thrust Select the line of thrust to set its color. 
Material number. Select one of the material numbers in the area beneath the 

Profile Lines to set the text color. 
<continued on next page> 
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Table 3.10 - continued 

Items Whose Color Can be Set 

Item Selection/Explanation 
Material property 
table grid lines 

Select any grid line in the material property table to set the color 
for all grid lines. 

Material property 
table text 

Select the material property text area (not grid lines) to set the 
text color. 

Material region (fill). Select the area beneath a Profile Line to set the color of the fill 
for the material beneath that particular Profile Line. 

“N-most” critical 
shear surfaces 

Select one of the “n-most” critical shear surfaces to set the color 
for  these surfaces.  (Note:  All n-most critical shear surfaces 
have the same color except the most critical shear surface which 
has a separate color.) 

Piezometric line 
points 

Select any point on a piezometric line to set the color for points. 
(Separate color assignments are made for Stage 1 and 2.) 

Piezometric line 
segments 

Select any segment of a piezometric line to set the line color. 
(Separate color assignments are made for Stage 1 and 2.) 

Piezometric line 
number 

Select any piezometric line number to set the text color. 
(Separate color assignments are made for Stage 1 and 2.) 

Profile line number Select any Profile Line number to set the text color. 
Profile line points Select any Profile Line point to set the color for points. 
Profile line segment Select any Profile Line segment to set the color for lines. 
Pressure 
interpolation point 

Select one of the points where pressures were specified to set the 
color for pore pressure interpolation points. Separate colors are 
used for pressure values, u  values, and shear strength values as 
well as for both Stages 1 and 2. 

r

Pressure 
interpolation triangle 

Select one of the triangles in the triangulation of data where pore 
pressure values were specified to set the triangle color.  Separate 
colors are used for pressure values, u  values, and shear strength 
values as well as for both Stages 1 and 2. 

r

Reinforcement point Select any point on a reinforcement line to set the point color. 
Reinforcement line 
segment 

Select a segment of any reinforcement line to set the line color. 

Reinforcement 
longitudinal force 
distribution. 

Select a portion of the outline of the distribution of longitudinal 
forces to set the longitudinal force distribution color. 

Reinforcement 
transverse force 
distribution. 

Select a portion of the outline of the distribution of transverse 
forces to set the transverse force distribution color. 

<continued on next page> 
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Table 3.10 - continued 

Items Whose Color Can be Set 

Item Selection/Explanation 
r

r

u  interpolation 
point 

Select one of the points where pore pressure coefficients 
( )were specified to set the color for  interpolation points. 
Separate colors assignments are made for pressure values, u  
values, and shear strength values as well as for both Stages 1 and 
2. 

ru ru

ru  interpolation 
triangle 

Select one of the triangles in the triangulation of data where pore 
pressure coefficient ( ) values were specified to set the triangle 
color.  Separate colors assignments are made for pressure values, 

u  values, and shear strength values as well as for both Stages 1 
and 2. 

ru

r

Shear surface 
effective stress 
distribution. 

Select a point on the outline of effective normal stress 
distribution on the shear surface to set the color for the 
distribution outline and fill. 

Shear surface pore 
water pressure 
distribution. 

Select a point on the outline of pore water pressure distribution 
on the shear surface to set the color for the distribution outline 
and fill. 

Shear surface total 
stress distribution. 

Select a point on the outline of total normal stress distribution on 
the shear surface to set the color for the distribution outline and 
fill. 

Slice boundaries Select either a slice or a boundary line between slices to set the 
color for drawing the vertical slice boundaries. 

Slope point Select any point on the slope to set the color for slope points. 
Slope line Select any segment of the slope line to set the slope line color. 
Strength 
interpolation point 

Select one of the points where shear strength values were 
specified to set the color for shear strength interpolation points. 
Separate color assignments are made for pressure values, u  
values, and shear strength values as well as for both Stages 1 and 
2. 

r

Strength 
interpolation triangle 

Select one of the triangles in the triangulation of data where 
shear strength values were specified to set the triangle color.  
Separate color assignments are made for pressure values, u  
values, and shear strength values as well as for both Stages 1 and 
2. 

r
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Table 3.11 

Items with Fill Patterns that Can be Set 

Item Selection/Explanation 
Material zones 
beneath Profile 
Lines 

To set the pattern used to fill a particular material, select the 
region where the pattern is to be set by clicking in the region 
immediately beneath the Profile Line.  Once a region is selected, 
use the Patterns menu to set the pattern. 

Distributed normal 
load. 

Select the distributed normal load to set the pattern for filling the 
distribution of normal stresses.  Then, set the pattern with the 
Pattern menu. 

Distributed shear 
load. 

Select the distributed shear load to set the pattern for filling the 
distribution of shear stresses. 

Effective normal 
stress distribution on 
shear surface. 

Select a point on the outline of the effective normal stress 
distribution on the shear surface to set the pattern for filling the 
stress distribution. 

Longitudinal force 
distribution in 
reinforcement. 

Select a portion of the outline of the distribution of longitudinal 
reinforcement forces to set the pattern for filling the load 
distribution diagram. 

Pore water pressure 
distribution on shear 
surface. 

Select a point on the outline of pore water pressure distribution 
on the shear surface to set the pattern for filling the pressure 
distribution. 

Total normal stress 
distribution on shear 
surface. 

Select a point on the outline of total normal stress distribution on 
the shear surface to set the pattern for filling the distribution. 

Transverse force 
distribution in 
reinforcement. 

Select a portion of the outline of the distribution of transverse 
reinforcement forces to set the pattern for filling the load 
distribution diagram. 
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the Patterns menu depending on the Graphics Configuration File.  The default 
configuration for TexGraf4 has twenty (20) patterns, including “None”. 

You can display the list of available patterns on the screen.  To do so choose the 
Display->Selections menu item and then check “Available Patterns” in the dialog box 
for display selections (Available Patterns is under the Miscellaneous tab in the Display 
Selections dialog box).  The Available Patterns item is one of the "special" Miscellaneous 
Display items; when chosen for display only patterns and other selected "special" items 
(available line styles and symbols) are displayed. 

Scaling 

The Scaling menu item is used to set the scaling information (scale factors) for 
the items listed in Table 3.12.  To set the scaling for a particular item first select the item 
and then choose the Settings->Scaling menu.  An appropriate dialog box is then 
displayed for you to set the scale information.  Further details on setting scales are 
described for various items below. 

X-Y Coordinate (Axes)  

When the coordinate axes are displayed the scaling can be set by first selecting 
either the horizontal or the vertical axis by clicking on one of the two axes and then 
choosing the Settings->Scaling menu item.  The dialog box shown in Figure 3.7 is then 
displayed for you to select the scaling.   

Initially all items are set automatically and the “Auto” check box for each item is 
checked.  If you change the value for an item by typing a new value in the corresponding 
text box, e. g. the starting x value, the Auto check box is cleared and the value that you 
entered is used.  If you later change your mind and decide that you want to have the value 
set automatically, you can do so by clicking on the Auto check box again.  The scaling 
parameters for the coordinate axes and their meaning are described further below: 

Starting X value, Starting Y value 

These are the starting world coordinate values for the x and y axes.  When these 
values are specified (rather than set automatically) the axes will start with these values. 

First X tick value, First Y tick value 

The first tick values designate the first value where tick marks and text 
representing the coordinate values begin.  If the values specified are less that the starting 
x value, the tick marks will begin at the first point where tick marks become visible if 
they started at the designated value and proceeded accordingly.  This depends on the tick 
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Table 3.12 

Items that Have Scaling Information 

Item Selection/Explanation 
Coordinate axes Select one of the two (x, y) coordinate axes to set the scaling for 

displaying the slope geometry and related items. 
Crack “water” force Select the horizontal vector representing the force in the crack to 

set the scaling for this force.. 
Distributed loads Select either a distributed load point or the outline of the stress 

distribution to set the scaling. 
Line loads Select either the tip or tail of the line load vector to set the 

scaling for the line loads. 
Reinforcement 
forces 

Select either (a) a point on a reinforcement line, (b) a segment of 
a reinforcement line, or (c) the outline of the distribution of 
longitudinal or transverse force in the reinforcement to set the 
scaling for the reinforcement force distributions. 

Stresses and 
pressures on the 
shear surface 

To set the scaling for distributions of stress along the shear 
surface select one of the following: (a) a point on the critical 
shear surface, (b) a segment of the critical shear surface/base of 
slice, (c) the outline of either the total normal stress, effective 
normal stress, or pore water pressure distribution on the shear 
surface. 
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Figure 3.7 – Coordinate Scaling Dialog Box  
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increment as well.  If the first tick value exceeds the largest value on the axis, no tick 
marks or coordinate values are displayed. 

X tick increment, Y tick increment 

The tick increments are the intervals in world coordinate units (e. g. feet, meters, 
etc.) between adjacent tick marks.  Axes will always be scaled so that there is at least one 
tick increment along each axis.  Because of this, if a tick increment is specified that is 
much larger than the total range of coordinate values for a problem, the scaling may be 
such that the display is very small. 

X axis length, Y axis length 

The axes lengths represent the physical length of the axis line drawn on the 
display or printer, independently of the world coordinates used for the problem.  The axis 
lengths may be specified in either inches or centimeters (see “Units”) below. 

Scale value 

The scale value is specified in terms of the world coordinate units (feet, meters, 
etc.) per display coordinate units.  The display coordinate units may be in either inches or 
centimeters; display coordinate units are chosen using the two radio buttons immediately 
below the scale value at the bottom of the dialog box shown in Fig. 3.7. 

Crack “Water” Force 

The force produced by water (or another fluid) in the tension crack is represented 
as a horizontal vector.  To set the scaling for this vector select the force and choose the 
Settings->Scaling menu item.   The dialog box shown in Fig. 3.8 is then displayed.  You 
can choose from five different options for scaling.  These options are described in Table 
3.13.  Depending on the option selected, you will need to enter an appropriate scale 
“factor”.  

Distributed Loads 

Distributed loads are represented as vectors and an outline of the distribution of 
stress.  The same scaling is used to display the normal and shear stresses.  To set the 
scaling select either a point where the distributed load was specified or the outline of the 
distributed load and choose the Setting->Scaling menu item.  The dialog box shown in 
Fig. 3.9 is then displayed for setting the scaling for the distributed loads.  The scale 
options are the same as those described in Table 3.13, except that stress (force/area) is 
used rather than force in setting the scaling.  For example, "load per world coordinate" 
units will be expressed by a scale factor expressed as stress per world coordinate unit. 
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Figure 3.8 –Dialog Box for Setting Scaling of the Water Force in a "Tension" Crack 
 
 
 
 
 
 
 
 

 
 

Figure 3.9 –Dialog Box for Setting Scaling for the Distributed Loads on the Surface of 
the Slope 
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Table 3.13 

Force Scaling Options Available When the Settings->Scaling Menu Item is Chosen 

Scaling Option Explanation 
Load per World 
Coordinate Unit 

The scale factor is expressed as the load per unit “distance” 
where “distance” is in the same units as the coordinates.  
For example, if load is in pounds and coordinates are in 
feet, you will enter the scale factor in pounds per foot.  The 
scaled distances for load distributions on the display will 
then depend on the scale factor for load as well as the scale 
factor for coordinate distances.  Depending on the amount 
you "zoom" in or out, the actual length of vectors on the 
display will change because the scaling for coordinates 
changes. 

Load per Inch The scale factor is expressed as the load per inch of display 
distance.  For example, if  the loads are in pounds, you will 
enter the scale factor in units of pounds per inch.  The 
length of a vector representing a given magnitude of load 
will then be independent of the coordinate scaling, e. g. the 
amount of "zooming" in or out. 

Load per Centimeter Similar to “Load per Inch” except display distances are 
expressed using centimeters rather than inches. 

Maximum Load in Inches The scale is set so that the vector representing the largest 
load has a specified, fixed length in inches, regardless of 
the magnitude of the load or the amount of zooming in or 
out.  You enter the length for the largest load in inches.  If, 
for example, you enter a value of 1 inch, the largest load 
vector will have a length of 1 inch and all smaller loads 
will have proportionately shorter lengths. 

Maximum Load in 
Centimeters 

Similar to “Maximum Load in Inches” except the length 
for the maximum load vector is specified in centimeters, 
rather than inches. 
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Line Loads 

Each line load is represented as a vector. To set the scaling select either the tip or 
tail of the line load vector and choose the Settings->Scaling menu item.  A dialog box 
like the one shown in Fig. 3.10 is then displayed.  The scale options are the same as those 
described in Table 3.13. 

Reinforcement Forces 

Longitudinal and transverse forces in reinforcement are represented by an outline 
of the distribution of force displayed immediately adjacent to each reinforcement line.  
The same scaling is used for the longitudinal and transverse forces.  To set the scaling 
select a point or segment of the reinforcing line or the outline of the distributed 
longitudinal or transverse force in the reinforcement and choose the Settings->Scaling 
menu item.  A dialog box like the one shown in Fig. 3.11 is then displayed for you to set 
the scaling information.  The scale options are the same as those described in Table 3.13. 

Stresses and Pressures on the Shear Surface 

The distribution of total and effective normal stress and pore water pressure along 
the shear surface are represented by an outline of the stress distribution on the base of 
each slice.  The same scaling is used for all three distributions (total stress, effective 
stress, pore water pressure).  To set the scaling for these distributions, select a segment of 
the outline of any one of the distributions and choose the Settings->Scaling menu item.  
The dialog box that is displayed is identical to the one displayed for setting the scaling 
for the (“crack” water) force in the vertical crack.  The scale options are the same as 
those described in Table 3.13, except that ‘load” is represented by stress (force/area) 
rather than by force in setting the scaling. 
 

Units and Scaling 

Different scaling is used with each different type of units (English, SI, "Other").  
When you set scaling values using the Scaling menu item, the scaling that you set is 
applied to the current type of units (See the Settings->Unit menu item for a description 
of the current type of units).  If you change the units, different scaling may apply; you 
will need to set scaling factors for each type of units separately.  When you save the 
Application Preferences, the scaling for all three types of units is saved. 

Factor of Safety Contours 

This menu item is used to set how the contours of factor of safety will be chosen 
and drawn.  When you choose this menu item the dialog box shown in Fig. 3.12 is 
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Figure 3.10 - Dialog Box for Setting Line Load Scaling 

 
 
 
 
 
 
 

 

Figure 3.11 - Dialog Box for Setting Scaling for Reinforcement Forces 
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Figure 3.12 - Factor of Safety Contour Settings Dialog Box 
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displayed.  The dialog box displays the minimum and maximum values of the factor of 
safety for the Current Data Set along with the current contour settings.  A drop-down list 
allows you to select a "Contouring Criterion":  You can select to draw contours using 
either (1) a nominal number of contours or (2) you can enter the specific values of factor 
of safety for which you want to draw contour lines.  If you choose the nominal number of 
contours, you will need to enter a number in the text box immediately below where you 
choose the contouring criterion.  The actual number of contours that will be drawn may 
differ from the number that you enter in order to ensure that a "nice", even contour 
interval is used. 

If you choose to enter the specific contour values, the text box for entering 
contour values (near the bottom of the dialog box) will become active and you can type 
in specific contour values.  To enter a specific contour value, type the value in the text 
box and click on the Add button.  If you want to change a value once you have entered it, 
click on the value in the list box where the values are displayed (just below the label 
"Contour Values") and re-type the new value in the lower text box.  When you are 
satisfied with the change, click on the Change button and the new value will replace the 
old value in the list.  To delete a value which you have entered, first click on the value in 
the list to select it and then click on the Delete button.  Once you have completed entry of 
information for drawing the contours, click on the OK button to dismiss the dialog and 
the new settings then go into effect. 

Units 

The Units menu item is used to set the current set of "units."  The current units 
determine which group of settings is to be used to scale loads (forces, stresses) and 
determine the numbers of decimals for displaying text5.  TexGraf4 maintains and stores 
as Application Preferences three groups of settings for scaling and defining the numbers 
of decimals used to display text.  These are associated with "English", "SI" and "Other" 
units.  Depending on which of these three "units" is selected, the corresponding default 
values are used.  If you change the units, the default values for scaling and the numbers 
of decimals used to display text are changed.  This may alter the display.  Be sure when 
you change the units that you have set appropriate values for the scaling and numbers of 
decimals for display.   

The Units menu has a sub-menu for you to select either English, SI or Other 
units.  A check mark will appear opposite the current set of units.  The default selection 
for "units" is stored in the Application Preferences. 

                                                 
5 The scaling for loads is set using the Settings->Scaling menu item; the numbers of decimals are set using 
the Settings->Decimal Points menu item. 
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Decimal Points … 

This menu item is used to set the numbers of decimal points that are used when 
numerical values are displayed as text.  When you choose this menu item the dialog Box 
shown in Fig. 3.13 is displayed.  Decimal points are set for each type of quantity (length, 
stress, force, etc.).  In addition for each quantity, you can designate whether the number 
of decimals is to be fixed, or the number is a maximum.  If you designate that the number 
is a maximum, any trailing zeros are eliminated and only the number of decimals 
required to display the non-zero digits are displayed. 

The numbers of decimals can be set for three different types of "units".  "Units" 
are actually just a convenient name for a particular configuration of decimal point 
settings and have no other formal meaning.  The first two types of units are labeled 
"English" and "SI".  The third type of units is labeled "Other" and can be used to set the 
number of decimals for any system of units that you want.  Too set the current "units" for 
teh display use the Settings->Units menu and select an appropriate set of units from teh 
units sub-smenu as described above. 

Normally you will use the dialog box shown in Fig. 3.13 to select the numbers of 
decimals for the current units.  However, you can also use the dialog to set the number of  
decimals for all three types of units (English, SI and Other) at one time.  To do so first 
choose the type of units that you want to set the decimals for using the drop-down list at 
the top of the dialog box.  Then set the desired numbers of decimals, including whether 
or not they are to be interpreted as the "Maximums" or as a fixed number of decimals.  
Next click on the Accept button to fix the decimal point information for the current set of 
units.  Repeat this process for the other types of units until all have been set to your 
satisfaction. The decimal points which you set will be stored for all three unit systems 
and saved as part of the Application Preferences.  Thus, you can use different settings for 
the numbers of decimals with different units all with one set of Application Preferences. 
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Figure 3.13 - Dialog Box for Setting Numbers of Decimals Used to Display Numerical 
Quantities as Text 

DXF File Drawing Layers 

The  DXF File Drawing Layers menu item is used to designate what drawing 
"layers" will be assigned to each type of information placed in the DXF file6.  When you 
choose this menu item the dialog box shown in Fig. 3.14 is displayed.  Click on the 
appropriate item that you want to specify the drawing layer for, e. g. Profile Line.  The 
current name assigned to the item will then appear in the edit box in the lower right-hand 
area of the dialog box.  Type a suitable name for the layer and then click on the Accept 
button to assign it.  The new layer name should then appear in the list of names in the 
upper portion of the dialog box. 

Layer names can contain letters, digits and the special characters hyphen (-), 
underscore (_) and dollar sign ($); layer names must not include blank spaces.  Layer 
names also must not exceed 31 characters. 

Layer names are stored in the Application Preferences.  If you want to use 
different sets of layer names for different problems or applications, you should create and 
save separate sets of preference files (See the File->Save Preferences to File and 
File->Read Preferences from File menu items.).   

                                                 
6 "Layer" information is only used for creating DXF files; otherwise layer information has no bearing on 
the screen or printed graphics. 
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Figure 3.14 - Dialog Box for Setting Layer Names for Items in DXF Files 

 

DXF File Line Styles 

The DXF File Line Styles menu item is used to designate what line styles are used 
for lines in the DXF drawing file7.  When you choose this menu item the dialog box 
shown in Fig. 3.15 is displayed.  To set the line style, select the item that you want to set 
the line style for by clicking on the item name in the list box in the upper portion of the 
dialog box.  The current line style will then appear in the edit text box near the lower left 
of the dialog box.  You can choose a line style from the drop-down list or type the name 
of a line style in the edit text box.  Once you have selected or typed the name of the 
desired line style click on the Accept button and the new line style will appear opposite 
the item name in the list box in the upper portion of the dialog box.  Repeat this process 
to set the line styles for other items. 

The names of available line styles that you can select from the drop-down list in 
the lower left portion of the dialog box is controlled by information in the Graphics 
Configuration File.  The Graphics Configuration File contains the names of available line 
styles (other than CONTINUOUS, which is always shown) that will be displayed in the 
drop-down list.  The Graphics Configuration File should be edited to include the line 

                                                 
7 DXF line style information is only used for creating DXF files; it has no bearing on the screen or printed 
graphics otherwise.  Line style information for the screen and printed graphics is set separately using the 
Settings->Line Style menu item. 
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styles that are available in the particular CAD software you are using.  You do not have 
to choose a line style from those in the list; you can type any line style name that is valid 
for your CAD software. 

 

Figure 3.15 - Dialog Box for Setting Line Styles for Items in the DXF File 

DXF File Item Colors 

The DXF File Item Colors menu item is used to set the colors assigned for 
various items in the DXF file8.  When you choose this menu item the dialog box shown 
in Fig. 3.16 is displayed.  To set the color for a particular item, first click on the item in 
the list box in the upper portion of the dialog box.  When  you select an item its name 
also appears above the drop-list in the lower left portion of the dialog box and the current 
color selection is shown.  If the current item color is one of the "standard" AutoCAD 
colors, the color name (and number in parentheses) appears in the drop-down list, and the 
edit box to the right of the list is made inactive (dimmed).  To choose a color you can 
either choose one of the standard colors from the list of colors or choose "other".  If you 
choose other as the color the edit box to the right of the list becomes active and you can 
type in the color number for the color than you want.  Colors must conform to the 
AutoCAD standard number system for colors and be either one of the standard colors or 
an integer from  0 through 255.  Other colors selections are not allowed. 

                                                 
8 DXF File color information only pertains to information in the DXF file; it has no bearing on the colors 
used for the display screen or printed output.  Color information for the screen display and printed output is 
set separately using the Settings->Color menu item. 
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Figure 3.16 - Dialog Box for Setting Colors for Items in the DXF File 

DXF File Miscellaneous 

The DXF File Miscellaneous menu item is used to set information regarding how 
points are represented in DXF files; it is only used when you are creating DXF files.  
When you choose this menu item the dialog box shown in Fig. 3.17 is displayed.  You 
can choose either to have points drawn as symbols like the ones drawn for the screen 
display and printed output, or you can have the points represented as Autodesk "Point" 
entities.  One advantage of having points displayed as Point entities is that their size can 
be set such that it is a fixed fraction of the display dimensions.  Thus, if you "zoom" in or 
out the points will remain the same size9.  Otherwise the size of points in the DXF file 
will increase and decrease as you zoom in and out, respectively.  

When points are displayed as Point entities their appearance (size and type of 
symbol) is controlled by the Autodesk system variables, PDMODE and PDSIZE.  If you 
check the check box to have points displayed as Point entities, the edit boxes opposite 
PDMODE and PDSIZE become active for you to enter appropriate values for your CAD 
software.  You will need to refer to your CAD software documentation to determine if 
Autodesk Point entities are supported and the meanings of the System Variables 
PDMODE and PDSIZE. 

                                                 
9 This may require that you "Regenerate" the drawing in AutoCAD. 
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Figure 3.17 - Dialog Box for Setting "Miscellaneous" Information for the DXF File 

Miscellaneous 

The Miscellaneous settings menu item is used to set special display options for 
the Profile Lines and material properties table.  When you choose this menu item the 
dialog box shown in Fig. 3.18 is displayed for you to make selections as described below. 

Profile line clipping 

If the original Profile Lines extend outside the region defined by the slope 
geometry data, you can choose to display either the original Profile Lines or have the 
Profile Lines “clipped” to the region within the slope.  Ordinarily the entire Profile Lines 
are displayed.  To display only the portion that is within the outline of the slope, click on 
the check box labeled “Clip profile lines to slope”. 

Material property table layout 

Ordinarily the material property table is displayed as a single column with one 
line of information for each material.  As an option, the material table can be laid out and 
displayed with the information arranged in two columns, side-by-side.  Each of the two 
columns will contain the information for approximately one-half the materials 
represented.  To choose how the material property data will be arranged click on either 
the radio button labeled "Single column" or "Two columns side-by-side".  The manner in 
which the material property table is displayed (one column vs. two columns) is saved as 
part of the Application Preferences. 
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Figure 3.18 – Miscellaneous Settings Dialog Box 
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Utexas Menu 

The Utexas menu is used to select the “Current Data Set".  When you first start 
TexGraf4 the Utexas menu contains just one item, labeled “none.”  As you read data sets 
into memory, either by choosing the File->Open menu item or choosing one of the files 
from the list of six most recently opened files (near the bottom of the File menu), an item 
is added to the Utexas menu as each data set is read.  The menu text for each new item is 
determined as follows: 

1. If a “Label” is entered as part of the original Utexas4 Group A input data for 
the data set, the label text is used as the text for the menu item, or 

2. If no label is entered, but at least one line of problem heading is entered with 
the original UTEXAS4 Group A input data, the first line of the problem 
heading is used as the text for the menu item, or 

3. If neither a Label nor a Problem Heading is entered, the Utexas menu text will 
appear as “Data Set Number xx (No heading or label)”, where “xx” represents 
the number of the data set (The first data set is the first set read, the second set 
is the second set read, etc.; set numbers are accumulated with each new set of 
data read.). 
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Window Menu 

The Windows Menu is used to “refresh” (ReDraw) the display screen, to activate 
automatic “tracking” of values with the cursor, to set information pertaining to the 
“Graphics Grid” which is used for reference, and to “zoom” and “pan” the display 
extents.  The Window Menu has fourteen (14) items which are discussed below. 

Redraw 

Use the Redraw menu item to refresh the display screen if the display has been 
corrupted.  Redraw also serves a special purpose when the display is scrolled using the 
scroll bars and either the Profile Line numbers, piezometrc line numbers or material 
numbers are displayed.  When you scroll the display the numbers remain at the same x-y 
location where they were first displayed, before scrolling was initiated.  Thus, it is 
possibly that they will be “scrolled” off the display.  If you specifically request that the 
display be redrawn, the location of the numbers will be recomputed to place them more 
optimally for viewing in the current coordinate “window”. 

Tracking On/Tracking Off 

When “tracking” is “on” values of a variable corresponding to the current 
selection and position of the cursor are displayed in the right-most panel of the Status Bar 
at the bottom of the main display window.  For example, if tracking is on and a 
piezometric line is selected, the value of the pore water pressure at the cursor location 
calculated from the piezometric line and displayed in the Status Bar.  The Tracking menu  
item is used to toggle tracking on and off.  Tracking and the types of information that can 
be “tracked” are described in Section 8 of this manual. 

Grid Settings… 

This menu item is used to setup the "Graphics Grid", which consists of a series of 
points arranged horizontally and vertically and a series of horizontal and verical lines.  
The Graphics Grid is intended for use as a reference for locating items and precise 
control of the cursor.  When you choose the "Graphics Grid" menu item a dialog box is 
displayed.  The dialog box allows you to enter the grid spacing (in world coordinate 
units) as well as to choose whether to display points, lines or both points and lines for the 
grid.  You can also choose to have the cursor "snap" to the grid.  If you choose to have 
the cursor snap to the grid, the coordinates displayed in the Status Bar at the bottom of 
the display window correspond to integer increments of the current grid spacing.  The 
spacing between grid points and lines is designated as an integer multiple of the grid 
spacing.  For example you might choose to have points displayed at intervals of 5 times 
the grid spacing and lines spaced at 10 times the grid spacing.  Then if you choose a 1 
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foot grid spacing and the "snap" mode is active, the cursor coordinates will change in 1 
foot intervals, and grid points and lines will be displayed at 5 and 25 foot intervals, 
respectively. 

Grid Snap On/Grid Snap Off 

Use this menu item to "toggle" the snap mode for the Graphics Grid on and off.  
The snap mode can also be toggled on and off by clicking on the Snap On/Off icon in the 
main Toolbar.  

Display Grid Points/Hide Grid Points 

This menu item is used to toggle the display of grid points on and off.  The grid 
point display may also be changed by clicking on the Grid Points Display icon in the 
main Toolbar or by choosing the Display->Grid Settings menu item and clicking the 
appropriate check box in the dialog box that is displayed. 

Display Grid Lines/Hide Grid Lines 

This menu item is used to toggle the display of grid lines on and off.  The grid 
line display may also be changed by clicking on the Grid Lines Display icon in the main 
Toolbar or by choosing the Display->Grid Settings menu item and clicking the 
appropriate check box in the dialog box that is displayed. 

Increase Grid Spacing 

Doubles the Graphics Grid spacing, e. g. if the current grid spacing is 1 foot, the 
grid spacing will be set to 2 feet.  The grid spacing may also be increased by either 
clicking on the Increase Grid Spacing icon in the main Toolbar or choosing the 
Display->Grid Settings menu item and changing the spacing in the dialog box that is 
displayed. 
 

Decrease Grid Spacing 

Decreases the Graphics Grid spacing to one-half the current spacing, e. g. if the 
current spacing between points in the Graphics Grid is 2 feet, the spacing will be changed 
to 1 foot.  The grid spacing may also be decreased by either clicking on the Decrease 
Grid Spacing icon in the main Toolbar or choosing the Display->Grid Settings menu 
item and changing the spacing in the dialog box that is displayed. 
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Zoom All 

"Zooms" the display to the full extent, showing the entire slope geometry.  The 
display may also be zoomed to the full extent by clicking on the Zoom All icon in the 
main Toolbar. 

 

Zoom Window 

Use this menu item to "zoom" in on a selected rectangular region of the display.  
When you choose this menu item a vertical and horizontal "crosshair" is displayed at the 
location of the cursor.  Use this crosshair to set the location of the first corner of the 
rectangular region that you want to zoom in on by clicking with the mouse.  Once you 
click to set the first corner a rectangle is displayed with one corner at the location where 
you clicked and the other corner at the current cursor position.  Move the cursor until the 
rectangle encloses the region that you want to zoom in on and click to set the second, 
opposite corner of the rectangle.  As soon as you set the second corner of the rectangle 
the display is updated to the new extent you have just selected.   

"Zoom Window" may also be activated by clicking on the Zoom Window icon in 
the main Toolbar.  To return the display to the original extent after zooming in choose the 
Zoom All item or use the Zoom Out function described below. 

Zoom Out 

This menu item allows you to "zoom" the current display region out by a factor of 
two.  When you choose this menu item, the cursor changes to a magnifying glass with a 
minus sign (-).  Each time you click the mouse at a point in the main display window the 
display "zooms" out with the geometry centered at the point you clicked.  You can 
repeatedly click in the main display window to zoom out further.  To terminate or cancel 
the "Zoom Out" mode either press the Escape (Esc) key or click the right mouse button, 
and the cursor returns to normal.  The Zoom Out function may also be activated by 
choosing the Zoom Out icon in the main Toolbar. 

Zoom In 

Similar to the Zoom Out function but instead "zooms" the display in by a factor of 
two each time you click in the display.  When you choose this menu item, the cursor 
changes to a magnifying glass with a plus sign (+).  Each time you click the mouse at a 
point in the main display window the display is magnified by a factor of two, centered at 
the point you clicked.  You can repeatedly click in the main display window to zoom in 
further.  To terminate or cancel the "Zoom In" mode either press the Escape (Esc) key or 
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click the right mouse button and the cursor returns to normal.  The Zoom In function may 
also be activated by choosing the Zoom In icon in the main Toolbar. 

Pan 

Use the Pan menu item to "pan" the geometry in the display window.  “Panning” 
translates the area of the geometry that is displayed in the window much like scrolling 
with the scroll bars. 

When you choose the Pan menu item a vertical and horizontal "crosshair" is 
displayed at the location of the cursor.  Use the cursor to locate the point that you want to 
pan (translate) in the display window by clicking at the point.  A vector (line) is then 
drawn between the point that you clicked and the current position of the cursor.  Use the 
vector to set the location that you want the point moved to by clicking at the new location 
for the point.  The display is then redrawn with the point at its new location.  The Pan 
function may also be activated by choosing the Pan icon in the main Toolbar. 

If the x-y coordinate axes are displayed when you pan, the amount of translation 
may not be exactly what you indicated with the “pan” vector because of the way that the 
axes are scaled.  After panning the axes are re-scaled to accommodate the translation that 
you specified and at the same time provide suitable values for the origins of the x-y axes 
and the increment for the tick marks.  Accordingly, the point that was moved may be 
adjusted to conform to the new scaling.  In any case the point that was panned will be 
visible in the display and at least near where it was panned. 

Fit to Print Area 

This menu item changes the size of the display window to match the printable 
area on the output page.  This can be used to view the display at the same size and scale 
that will be used when the display is printed.  When you use this feature you will 
normally choose this menu item first to set the size of the display window and, then, 
adjust the display using the Zoom All, Zoom Window, Zoom In, Zoom Out and Pan 
functions to set the extent of what is displayed in the window. 

 



 

Section 4 – TOOLBAR 
TexGraf4 has a single toolbar containing a number of small icons.  Initially the 

Toolbar is displayed at the top of the main display window, but it can be dragged to other 
locations in the main display window. The TexGraf4 Toolbar is shown below in Figure 
4.1. 

 

 

Figure 4.1 - TexGraf4 Main Toolbar 

The Toolbar can be used to access a number of the functions that are also 
accessible through the TexGraf4 menus described in Section 3.  Each item (icon) in the 
Toolbar is briefly described below.  For more details on the icons refer to the description 
of the various TexGraf4 menus in Section 3. 

 New File Icon 

Opens and reads a Graphics Exchange File ("*.UT4") created by UTEXAS4.  
Before reading data from the file all data that are currently in memory are deleted. 

 File Open Icon 

 Opens and reads a Graphics Exchange File created by UTEXAS4.  The information 
will be added to any information already in memory.  Performs the same function as the 
File->Open menu item. 

  Print Icon 

Prints the information displayed in the main display window to the current 
printer. 
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  About Icon 

Displays the "About" dialog for TexGraf4. 

 Zoom All Icon 

"Zooms" to display the full extent of the problem geometry in the main display 
window.  See the Window->Zoom All menu item for more details. 

 Zoom Window Icon 

Allows you to set the extent of the display window using a dynamically 
positioned "box".  See the Window->Zoom Window menu item for more details. 

 Pan Icon 

Allows you to "pan" the display window using a dynamic positioning vector. See 
the Window->Pan menu item for more details. 

 Zoom In Icon 

Allows you to "zoom in" by a factor of two by clicking with the mouse. See the 
Window->Zoom In menu item for more details.  

  Zoom Out Icon 

Allows you to "zoom out" by a factor of two by clicking with the mouse. See the 
Window->Zoom Out menu item for more details.  

  Grid Snap Icon 

Turns the Graphics Grid "snap" mode on and off. See the Window->Grid Snap 
On/Grid Snap Off menu item for more details.  
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  Display Grid Points Icon 

"Toggles" the display of Graphics Grid points on and off. See the 
Window->Display Grid Points/Hide Grid Points menu item for more details.  

  Display Grid Lines Icon 

"Toggles" the display of Graphics Grid lines on and off. See the 
Window->Display Grid Points/Hide Grid Points menu item for more details.  

  Increase Grid Spacing Icon 

Doubles the spacing for Graphics Grid points. See the Window->Increase Grid 
Spacing menu item for more details.  

  Decrease Grid Spacing Icon 

Halves the spacing for Graphics Grid points. See the Window->Decrease Grid 
Spacing menu item for more details.  
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Section 5 – GRAPHICAL DISPLAY OF ITEMS 
This section describes the information displayed by TexGraf4.  The graphical 

representation of the information and the settings that can be made to control how the 
information is displayed are also explained.  The specific items that are displayed are 
determined by selections made using the Display->Selections menu item and the dialog 
box that is displayed for you to make selections. 

The first part of this section explains the graphical representation of data that are 
entered as input data to UTEXAS4; the latter parts describe the graphical display of the 
computed results and information generated by UTEXAS4. 

Input Data – Stages 1 and 2 

Input data for conventional (single-stage) and the first stage of multi-stage 
computations are displayed independently of data used for the second and third stage 
computations.  Data for either stage or both stages may be displayed depending on the 
selections made using the Display->Selections menu item.  The dialog box for making 
the display selections has separate tabs for the first stage and the second stage data.  
Except for differences in color and style used to display lines and points, the display of 
information for both stages is very similar and, thus, no distinction between the data for 
different stages is made in the explanations below. 

Profile Lines, Points and Numbers. 

Profile Lines are displayed as a series of straight line segments connecting the 
points that define the Profile Line.  Unless “Profile Line clipping” is activated (as 
described later below), the points that are displayed are the points that were specified in 
the input data for UTEXAS4.  Points are displayed as symbols, e. g. solid circles, open 
squares, etc.  Depending on your selections either the lines, the points or both lines and 
points can be displayed.   

Set the color, style and weight for drawing the Profile Lines using the Settings 
menu.  The Settings menu is also used to set the type of symbol, the size of the symbol 
and the color of the symbol used to draw points.  By setting the line weight used to draw 
symbols you can also change the appearance of a symbol.  The line weights used to draw 
lines and to draw points (symbols) can be set separately. 

The numbers assigned to Profile Lines in the UTEXAS4 input data can also be 
displayed.  The numbers are displayed as text superimposed on the Profile Line at the 



  65   

midpoint of the longest visible segment of each Profile Line.  Numbers are outlined with 
a rectangular or square box.  The Settings menu is used to change the font used to draw 
the numbers and the color of the text. 

UTEXAS4 allows you to define a soil profile that extends outside the limits of the 
slope geometry.  In this case a separate slope line (Group F Input Data) defines the 
surface profile of the slope.  Normally, TexGraf4 displays the full extent of the Profile 
Lines, including portions that extend outside the limits of the slope.  However, if you 
wish to display only the portions of the Profile Lines that lie within the slope you can 
choose to activate “Profile Line Clipping” using the Miscellaneous item in the Settings 
menu.  If you choose to have the Profile Lines “clipped” to the slope, the points that are 
displayed are a combination of some of the points that were entered as input data and 
(possibly) additional points that were computed when the Profile Lines were “clipped” to 
the slope. 

Material “Fills” 

The areas beneath Profile Lines can be filled with a patterned fill to represent the 
different types of materials in the soil profile.  The color and pattern used for the fill can 
be set by first clicking in the region representing a particular material to select the region.  
The color and pattern are then set by choosing the desired color and pattern, respectively, 
from the Settings menu. 

Material Numbers 

The numbers assigned to materials in the UTEXAS4 input data can be displayed 
in the regions beneath the Profile Lines.  The location of each number is determined by 
UTEXAS4 using an algorithm that attempts to locate the number in the largest, visible 
region of each material.  Material numbers are outlined with a circle drawn in the same 
color as the material number.  To change the font or color used to display the number, 
first select the number of any material and then choose either Font or Color, 
respectively, from the Settings menu. 

Material Property Table 

A table containing the material properties is automatically generated and 
displayed if you choose.  For each material the table contains the material number, the 
description of the material, the unit weight, the shear strength, and the pore water 
pressures.  Set the characteristics of the font used to draw the table by selecting either the 
text in the table or one of the interior or exterior border lines in the table and choosing the 
Settings->Font menu item. 

The line weights for both the interior and exterior border lines in the material 
property tables can be set by selecting an appropriate line and choosing the Settings-
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>LineWeight menu item:  Choose an exterior line to set the line weight for the outer 
boundary of the table; choose any interior line to set the interior line weight.  Only two 
line weights are used (interior, exterior) so it doesn’t matter which particular interior or 
exterior border line you select for setting line weights.  All lines in the table are drawn as 
solid lines; “styles” cannot be set for the lines in the material properties table.   

Colors for both the text and border lines are set by selecting an appropriate item 
(text, line) and choosing the Settings->Color menu item. 

A material property table may be relocated on the display by selecting and either 
dragging the table or initiating a "move" by choosing the Edit->Move Material 
Property Table item.  Section 7 of this manual gives further details on relocating items 
on the display. 

Piezometric Line, Points and Numbers 

Piezometric line are displayed much like Profile Lines.  Lines, points and 
numbers may all be displayed for the piezometric lines.  The display of piezometric lines 
differs from the display of Profile Lines only in the particular choice of line weights, 
colors, styles, fonts, etc. that are used.  Piezometric line numbers are also surrounded by a 
triangular frame rather than the square/rectangular frame that surrounds Profile Line 
numbers. 

Interpolation Data Points for Pore Pressure, ru and Shear 
Strength 

The individual points entered as input data to UTEXAS4 for interpolating values 
of pore water pressure, pore water pressure coefficient ( ) and shear strength are 
displayed as symbols drawn at the location of each point.  Generally different symbols 
are drawn for each of the three types of interpolation data (pore water pressures; pore 
water pressure coefficients, ru; undrained shear strengths).  The type of symbol, color of 
symbol and size of symbol may be set using the Settings menu.  The line weight for the 
symbols may also be set using the Settings menu.  Different settings are used for each 
stage and must be set independently. 

ru

A Delauney triangulation is constructed for each set of interpolation data points; 
the triangulation is used by UTEXAS4 for interpolating values of the appropriate 
variable.  The triangles making up the triangulation are displayed by TexGraf4 as a series 
of straight lines connecting the various interpolation points making up the boundaries of 
the triangles. (Note:  Selection of the display of the triangles is under the 
“Miscellaneous” tab in the Display Selections dialog box.)  The color, weight and style of 
lines for the triangles may be changed by selecting a triangle for a particular set of 
interpolation data and choosing the appropriate item (Line Weight, Line Style, Color) 
from the Settings menu. 
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Slope Line and Points 

The line representing the surface profile of the slope and the points defining this 
line are displayed in much the same way that Profile Lines and piezometric lines are 
displayed.  If the slope line is entered directly as part of the input data for UTEXAS4, the 
points displayed are the points that were entered with the input data.  If instead, the slope 
geometry data are created by UTEXAS4 from the Profile Line data, the points are 
whatever points were computed by UTEXAS4.  In some cases there may be extra, 
unnecessary points, i. e. where a series of points all lie along the same straight line.  
However, this has no adverse effect of the results from UTXAS4. 

Distributed Loads 

Distributed loads are displayed as a series of vectors and an outline representing 
the magnitude of the stress distribution.  Symbols are also displayed at each point where 
the distributed load was specified in the input data for UTEXAS4.  If the distributed 
loads were generated from the data for a piezometric line, the points will be the points 
that UTEXAS4 determined when it generated the data.  In some cases there may be extra 
points, e. g. where points all lie along a straight line and the distributed loads vary 
linearly along the line.  However, such extra points have no adverse effects on the results 
from UTEXAS4. 

Distributed loads are scaled according to scale factors that are initially set based 
on Application Preferences (units and default scale factors).  These may be changed by 
first selecting a segment of the outline of the stress distribution (the line running through 
the “tails” of the vectors) and then choosing the Settings->Scaling menu item.  If you 
want to change the default scaling, set the scaling for the current set of units and then 
save the Application Preferences. 

The normal stress distribution, shear stress distribution or both normal and shear 
stress distribution are displayed depending on what is chosen in the Display Selections 
dialog box.  If only the normal stress distribution is displayed the vectors are plotted so 
that they act perpendicular to the surface of the slope.  If only the shear stress distribution 
is displayed, teh shear stress is also displayed as a set of vectors that act perpendicular to 
the surface of the slope; the length of the vectors is scaled according to the scale factor 
and represents the magnitude of the shear stress.  If both the shear and the normal stress 
are selected for display, the vectors represent the resultant due to the shear and normal 
stress component and act in the direction of the resultant force.  In this case the vectors 
will not be perpendicular to the surface of the slope except at points where the shear 
stress is zero.  

The line weight and color used to draw the stress distribution can be set by 
selecting the outline of the stress distribution and then choosing the appropriate item 
(Line Weight, Color) from the Settings menu.  You can also fill the stress distribution 
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with a patterned fill by selecting the stress distribution and selecting a pattern from the 
Settings->Patterns menu.  The size, color and symbol used to plot points where the 
stress distribution was specified can also be set by selecting a point and then choosing the 
appropriate menu item from the Settings menu.  Similarly, the line weight used to draw 
symbols is changed by selecting a point and choosing the Settings->Line Weight menu 
item. 

Line Loads 

Line loads are displayed as vectors (lines with arrowheads) at the locations where 
the line loads act.  The vectors are scaled in accordance with the scale factors which are 
set initially by information in the Application Preferences and can be changed using the 
Settings->Scaling menu.  Different scaling information is set and stored for each of the 
three types of "units" (English, SI and Other).  Changing the units using the 
Settings->Units menu item may change the scaling depending on the scale that 
information has been set for each type of units.   

The line weight and color for drawing line loads can be changed using the 
Settings menu.  To change the scaling, color, line weight, etc for the line loads you must 
first select a line load.  This is done by clicking on either the tip or the end of the tail of 
the vector; you cannot select a line load by clicking at an intermediate point along the 
shaft of the line load. 

Reinforcement Lines, Points and Force Distribution 

Reinforcement lines and the points defining the reinforcement lines can both be 
displayed.  In addition the distribution of longitudinal and transverse force in the 
reinforcement can be displayed.  The display of reinforcement lines and points is very 
similar to the display of Profile Lines and piezometric lines.  The line weights, colors, 
point sizes and symbols used to represent points can all be changed by selecting either a 
point or line (depending on what is to be changed) and choosing the appropriate item 
from the Settings menu. 

The distributions of longitudinal and transverse forces in the reinforcement are 
displayed as outlines representing the magnitude of the force distribution.  The forces are 
scaled in accordance with scaling information in the Application Preferences and can be 
changed using the Settings->Scaling menu item.  Different scaling information is set and 
stored for each of the three types of "units" (English, SI and Other).  Changing the units 
using the Settings->Units menu item may change the scaling depending on what scale 
information has been set for each type of units. 
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The distributions of longitudinal and transverse forces are displayed 
independently by two separate outlines of the distributions10.  For both longitudinal and 
transverse forces the perpendicular distance between the reinforcement line and the 
outline of the force distribution is proportional to the magnitude of the respective force in 
the reinforcement, and depends on the current scaling. 

The line weight and color used to draw the outlines of the reinforcement force 
distributions may be changed by selecting the distributions and then choosing the 
appropriate item in the Settings menu.  The line weights and colors used to draw the 
longitudinal and transverse force distributions are independent of each other and different 
settings and may be used for each.  The outline of the force distributions in the 
reinforcement can also be filled with a patterned fill.  The fill pattern is set initially based 
on Application Preferences and can be changed using the Settings->Patterns menu.  
Again, different patterns may be used for the longitudinal and transverse force 
distributions.  However, when both the longitudinal and transverse force distributions are 
filled it may be difficult to see the underlying distribution of one force component 
because it is covered by the other.  Filling the reinforcement force distributions with 
patterns is not recommended when the reinforcement carries both longitudinal and 
transverse forces and both sets of forces are displayed. 

Initial Shear Surface 

The initial shear surface that is specified either as an individual shear surface to 
be analyzed or as the initial trial shear surface for a search is displayed as either a circular 
arc or a series of straight line segments depending on whether the shear surface is circular 
or noncircular, respectively.  For noncircular shear surfaces the points that were specified 
to define the shear surface may also be displayed.  Information pertaining to the line 
weight, line and point color, point size, symbol types, etc. is set in much the same way 
that this information is set for Profile Lines and piezometric lines. 

For circular shear surfaces the center point for either the individual circle that was 
specified or the initial trial circle for an automatic search is also displayed.   The center is 
displayed by a cross (+) and two lines drawn from the center point to each of the two 
extreme, outer ends of the circle. The color and line weight as well as the size of the 
symbol drawn for the center point of the circle can all be set by selecting the center point 
and choosing the appropriate item from the Settings menu.  For searches performed with 
a fixed grid, there is no specific initial trial circle and this information is not displayed.   

                                                 
10 This differs somewhat from how distributed loads on the surface of the slope are represented.  When 
both normal and shear components are displayed for the distributed loads on the surface of the slope, they 
are displayed as a single distribution representing the resultant of the two components.  For reinforcement 
forces the two components (longitudinal and transverse) are displayed separately. 
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Specified Search Grid 

For automatic searches performed with circles the initial grid for the search is 
displayed.  The grid displayed will differ depending on whether a “floating’ or “fixed” 
grid was used.  For a floating grid the display consists of two square, 3 x 3 (9-point) 
grids, both with the same center point; the center point is the center of the initial trial 
circle.  Each of the two grids is represented by a series of three horizontal and three 
vertical lines whose intersections represent the nine points in each grid.  One grid is very 
large and the spacing between points corresponds to the coarse initial spacing that is used 
in the search.  The second grid is much smaller and corresponds to the finest grid used for 
the search; the spacing for this grid is part of the input data for UTEXAS4.  For searches 
performed using a fixed grid, the complete fixed grid is drawn.  The line weight and color 
used to draw the search grids can be set by selecting the grid and choosing the 
appropriate item in the Settings menu. 

Crack and Crack Water Information 

Both the crack and any water in the crack are displayed graphically.  The crack is 
displayed by a line representing the bottom of the crack with vertical “hatching” running 
from the bottom of the crack to the ground surface.  Both the line weight and the line 
style for the line representing the bottom of the crack may be set by selecting a segment 
of the crack bottom and choosing the appropriate item from the Settings menu.  The 
vertical hatching is always drawn using solid lines with a line weight of 1 point; this 
cannot be changed.  The color of both the crack base line and the vertical hatching is set 
by selecting a point on the base line of the crack and choosing the Settings->Color menu 
item. 

If there is water in the vertical tension crack, a line is drawn representing the 
surface of the water.  Vertical hatching is also drawn running from the water surface to 
the bottom of the crack. The vertical hatching is drawn such that the vertical hatch marks 
are located approximately midway laterally between the vertical hatch marks 
representing the crack.  Both the line weight and line style for the line representing the 
water surface may be set by selecting a segment of the water surface and choosing the 
appropriate item from the Settings menu. The vertical hatching representing the water is 
always drawn using solid lines with a line weight of 1 point; this cannot be changed. The 
same color is used for both the water surface and the vertical hatching and is set by 
selecting a point on the water surface and choosing the Settings->Color menu item. 

Results 

Results of computations are displayed when the computations with UTEXAS4 are 
completed successfully.  If the computations are not successful only the input data are 
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displayed.  The various information from the computed results that can be displayed is 
described below. 

Computed Factor of Safety 

The computed factor of safety for either an individually specified shear surface or 
a critical shear surface (in the case of an automatic search) is displayed as text.  When 
Spencer’s procedure is used the corresponding value for the side force inclination is also 
displayed. 

The color and font used to display the computed factor of safety is changed by 
selecting the text and then choosing the Settings->Color and Settings->Font menu 
items, respectively. 

You can also move the text for the computed factor of safety by selecting it and 
dragging it to a new location.  The procedure for doing this differs somewhat depending 
on whether the text is located at the same area as other items (e. g. the material property 
table, Profile Lines, etc.) or if the text is displayed in an area away from any other 
objects.  If the text is displayed away from the location of any other items, you can 
simply click on the text and while continuing to hold the mouse button down, drag the 
text to its new location.  If instead the text lies over other items, when you click on the 
text a menu will pop up for you to choose the item to be selected.  If you choose 
“Computed answer (factor of safety) text” from the pop-up menu, you can then move the 
text by choosing Move Factor of Safety Text from the Edit menu.  The Edit menu  only 
displays this option (Move Factor of Safety Text) when the text is selected.  The Edit 
menu normally just displays a Move item and “Move” is grayed out unless a movable 
item (factor of safety text or material property table) is selected. 

Critical (or Individual) Shear Surfaces. 

Either the individually specified shear surface or the critical shear surface (in the 
case of an automatic search) is displayed as a series of symbols at points along the 
surface and straight line segments connecting the points.  The points are displayed at the 
locations of the vertical boundaries of the slices.  For the lines the color, line weight and 
line style may be set by choosing a segment of the shear surface (base of slice) and 
choosing the appropriate item from the Settings menu.  Similarly for the symbols plotted 
at points, the color, line weight, symbol type and symbol size can be set by selecting a 
point on the shear surface and choosing the appropriate item from the Settings menu. 

When an individual shear surface (not a search) has been specified, the shear 
surface drawn as part of the “Results” display is at the same location as the shear surface 
drawn as part of the “Input Data”, i. e. two shear surfaces are drawn at the same location.  
However, the display of each of the two shear surfaces is different:  For circles the 
“input” circle is plotted as a continuous arc without regard to where slices are located; no 
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points are plotted along the "input" circle.  In contrast the “results” circle is plotted as a 
series of straight line segments representing the bottom of the slices; with points where 
each slice boundary exists.  For noncircular shear surfaces both the “input” and “results” 
shear surfaces are plotted as a series of straight line segments connecting points along the 
surface; however, for the “input” shear surface the points are the points that were entered 
as input data to define the noncircular shear surface.  For the “results” shear surface the 
points are at the boundaries between slices. 

For automatic searches with circles using either a “floating grid” or “fixed grid" 
(Type 1 or Type2 search, respectively) the center of the “critical” circle with the lowest 
factor of safety can also be displayed.  The center is displayed by a cross (+) with two 
lines drawn from the center to the two extreme ends of the circular arc.  The color and 
line weight used to draw the center and two radii can be changed by selecting the center 
point and choosing the appropriate item from the Settings menu.  For individually 
specified circles the center point and two radii can be drawn by displaying the center for 
the initial (input) shear surface as described for the input data. 

Factor of Safety Contours 

Contours representing constant values of factor of safety can be drawn when an 
automatic search has been performed using a Type 2, "Fixed Grid" search.  The contour 
interval used to draw contours can be set by first selecting a contour line by clicking with 
the mouse and then choosing the Settings->Factor of Safety Contours. You can also 
change the line weight and color for the contours by selecting one of the contour lines 
and then choosing the appropriate item from the Settings menu.  The font used to label 
the contour is changed by selecting a contour and choosing the Settings->Font menu 
item. 

 

"N-Most" Critical Shear Surfaces 

TexGraf4 displays each of the "n-most" critical shear surfaces from an automatic 
search if you have specified that UTEXAS4 was to save them.  These "n" surfaces are 
displayed independently and in addition to the most critical shear surface described 
earlier above.  Actually the most critical shear surface may be displayed twice, once 
because it is the most critical shear surface and again because it is a member of the "n-
most" critical shear surfaces.  The settings for displaying the most critical shear surface 
information described earlier are made entirely independently of the settings used to 
display the n-most critical shear surfaces.  You can change the line weight and color used 
to display the n-most critical shear surfaces using the Settings menu.  You cannot 
selectively choose which of the n-most critical shear surfaces is displayed, nor can you 
set separate line weights and colors for individual shear surfaces among the n-most 
critical ones.  All of the "n-most" critical shear surfaces are displayed when any one of 
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the n-most critical shear surfaces is displayed.  Also the same settings are used for all of 
the n-most critical shear surfaces when they are displayed. 

Slices 

Vertical lines are drawn to represent the boundaries between slices for either the 
individually specified or the most critical (in the case of an automatic search) shear 
surface.  You can set the line weight, line style and color for the vertical lines using the 
appropriate Settings menu items. 

Force Vector for Water in Crack 

A horizontal vector is drawn to represent the force of water in the vertical 
"tension" crack.  You can set the line weight and color used to draw the vector by 
clicking on the vector to select it and then using the appropriate Settings menu item.  To 
set the scaling used to draw the vector, first select the vector by clicking on it and then 
choose the Settings->Scaling menu item. 

Total Normal Stress, Effective Normal Stress and Pore Water 
Pressure Distributions on Shear Surface 

The distributions of total normal stress, effective normal stress and pore water 
pressure along the shear surface are displayed by drawing a quadrilateral outline 
representing the magnitude of the stress on the base of each slice.  Positive stresses are 
plotted below the shear surface, negative stresses are plotted above the shear surface 
(inside the slide mass). 

The line weight used to draw the outline of the distribution, the pattern used to fill 
the area inside the rectangular outline and the color may all be selected independently for 
the total stress, effective stress and pore water pressure distributions.  To set these items 
first select a segment of the outline of the distribution representing the magnitude of the 
stress (the portion furthest from the base of the slice) and then choose the appropriate 
Settings menu item to set how the information is to be displayed.  Negative stresses are 
displayed using different settings for the line weight, fill pattern and color from the ones 
used to display positive values of the stresses.  To change the settings for negative values 
select a portion of the distribution where the stresses are negative; settings for positive 
values are made by selecting portions of the distribution where the stresses are positive. 

The scale factors used to plot stress distributions can be changed by selecting the 
outline of the stress distribution as described above and then choosing the 
Settings->Scaling menu item. 
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Line of Thrust 

The "line of thrust" is the line drawn through points where the side forces are 
located on the boundaries between each slice.  The line of thrust is displayed as a line 
running from the left to the right of the shear surface.  The line weight, line style and 
color used to display the line of thrust can be set by first selecting a segment of the line of 
thrust by clicking on it with the mouse and then choosing the appropriate Settings menu 
item. 

Miscellaneous 

"Miscellaneous" items that can be displayed include "Problem-Related" items and 
"Special Items".  These are each discussed separately below. 

Problem-Related Items 

Problem-Related items consist of a set of x-y coordinate axes, triangles 
representing the Delauney triangulation used for interpolation of pore water pressures 
and shear strengths, and an outline representing the area that will be printed on the 
printed output page.  Except for the rectangle representing the print area, all of these 
items will be included in the printed output if they are displayed in the main display 
window. 

X-Y Coordinate Axes 

A set of x-y coordinate axes can be drawn to show the coordinates currently being 
displayed.  Scaling for the axes can either be done automatically or set manually using 
the Settings->Scaling menu item (See Section 3 on menus).  When the axes are 
displayed only the portion of the geometry inside the limits of the axes is scrolled when 
you scroll the display; the lines representing the two axes are not moved.  However, if 
you scroll the display and the axes are displayed, the coordinate values and tick marks 
along the axes are adjusted ("scrolled") to reflect the shift in coordinates. 

The line weight, color and font used to draw the axes and text labels can be set by 
first clicking on one of the axes to select it and then choosing the appropriate item from 
the Settings menu. 

Triangulations 

Separate Delauney triangulations are created by TexGraf4 to interpolate values of 
pore water pressure and shear strength and to draw contours of factor of safety (when a 
Type 2, "Fixed Grid" search is performed).  Triangulations are automatically created for 
each set of pore water pressure, pore water pressure coefficient (ru), and shear strength 
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interpolation data points entered as input to UTEXAS4.  Triangulations are also created 
for the grid points used in a Type 2, fixed grid search with circles.  The triangulation of 
the search grid points is not used in the actual slope stability computations, but is used to 
draw contours in TexGraf4.  Each of these triangulations is displayed by lines connecting 
adjacent vertices of each triangle.  The primary purposes for displaying these triangles is 
to provide you with insight into how interpolation is done and to understand why a 
particular pattern of contours is drawn for the factor of safety. 

The line weight, line style and color used to display the triangles can be set by 
first selecting a triangle of the type for which you wish to change the settings and then 
choosing the appropriate item in the Settings menu.  All triangles for a given type of data, 
e. g. shear strength values for the first stage computations have the same display 
parameters (line weight, color, etc.), but each different type of data (pore water pressure, 
shear strength, etc.) and each stage have different display settings.  Select the appropriate 
type of data to change the settings for it. 

Print Area Rectangle 

A rectangle can be superimposed on the display to show the approximate size of 
the printed page relative to the current scale of the display in the main display window.  
This may be useful for setting font sizes and scaling for forces and stresses to achieve the 
appropriate proportions in the final printed output.  The orientation and size of the 
rectangle depend on the current printer selections. 

Special Items 

"Special items" consist of the various available line styles, symbols, etc. that can 
be used to display graphics.  The special items are displayed primarily to help you in 
choosing display settings;  the special items display can be printed for your reference in 
choosing display settings.  When one or more "special" items are displayed, only the 
special items are displayed; none of the slope information, coordinate axes, etc. is 
displayed regardless of the selections made in the Display Selection dialog box. 

Available Patterns 

When the "Available Patterns" item is selected for display, a series of rectangles 
is displayed.  Each rectangle is numbered and filled with one of thirty-eight (38) different 
patterns that can be used to fill areas.  The use of patterns for filling areas is described in 
Section 3 where the Settings->Pattern menu item is described. 

The Settings->Patterns sub-menu lists many, but not all of the available patterns.  
The specific patterns which are shown and available for assignment in the 
Settings->Patterns sub-menu are set by information in the Graphics Configuration File.  
TexGraf4 allows you to set in the Graphics Configuration File up to twenty (20) of the 
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available patterns for assignment using the Settings->Patterns menu; all thirty-eight 
patterns can never be used or assigned at the same time. 

Available Line Styles 

The Available Line Styles display selection displays the line styles that are 
available and can be assigned using the Settings->Line Style menu item.  The available 
line styles that are shown in Figure 3.5 were actually drawn on the computer display 
screen using the "Available Line Styles" display option and then "captured" for insertion 
as a graphic into the text for this manual. 

Available Symbols 

The available symbols that can be used to draw points can be displayed by 
choosing the "Available Symbols" display option.  These are the symbols that can be 
assigned using the Settings->Point (Symbol) Type menu item.  Figure 3.6 shows the 
available symbols and was actually drawn on the computer display screen using the 
"Available Symbols" display option and then "captured" for insertion as a graphic into 
the text for this manual. 
 

 



 77 

 

Section 6 – SELECTING ITEMS 
TexGraf4 lets you select items that are displayed on the screen.  Items are 

selected to get information that is then displayed in the Status Bar, and to set how 
information is displayed (See the Settings menu).  In order to select an item it must be 
displayed and must generally be a member of the “Current Data Set"; the Current Data 
Set is described in the section on the Utexas menu.  Only the x-y coordinate axes do not 
belong to a particular data set; the coordinate axes can be selected regardless of the 
Current Data Set. 

Items are selected by positioning the cursor over the item and clicking the left 
mouse button.  If multiple items exist at the point where you clicked, a menu is “popped-
up” listing the items at that location.  Use the menu to choose which item to select. 

Items must be displayed to be selected.  For example, if you display the Profile 
Lines, but not the points (symbols) for the Profile Lines, you will not be able to select 
points.  The items that can be selected and the location that must be clicked to select them 
are listed in Table 6.1. 



  78   

Table 6.1 

Items that Can be Selected 

Item How to Select Item 
“Crack” line Click on a segment of the line representing the bottom of the 

tension crack. 
“Crack” point Click on one of the points that define the bottom profile of the 

crack (these points are never actually displayed). 
“Crack” water force Click on the horizontal vector that is drawn to represent the 

force in the vertical “tension” crack. 
“Crack” water line 
segment 

Click on a segment of the line representing the surface of the 
water in the tension crack. 

Critical circle center Click on the center point of the critical circle to select it.  
(Only applies to automatic searches with circles.) 

Critical shear surface 
point 

Click on one of the points on the critical shear surface to select 
it. 

Critical trial shear 
surface line 

Click on a segment of the critical shear surface (between 
coordinate points) to select it.  Segments of the critical shear 
surface coincide with the base of individual slices. 

Distributed load point Click on one of the points where the distributed load is 
specified. 

Distributed load 
normal distribution 

Click on the tail end of the distributed load vectors or on the 
line drawn to connect the tail of the vectors that represent the 
normal component of the distributed load. 

Distributed load shear 
distribution 

Same as selecting the normal load except click on the shear 
load distribution.  Note:  If both shear and normal loads exist 
the distribution represents the resultant of the normal and shear 
component; only the resultant is drawn and can be selected. 

Factor of safety Click on the text representing the computed factor of safety 
(and side force inclination, if applicable). 

Factor of safety 
contours. 

Click inside the area of the grid used for the search.  Use the 
pop-up menu that is displayed to select the contours, rather 
than the triangulation of grid points or the grid lines.  Only 
applicable to searches conducted with the “fixed” grid. 

Factor of safety 
triangles 

Click inside the area of the grid used for the search. Use the 
pop-up menu that is displayed to select the triangles, rather 
than the contours or the grid lines.  Only applicable to searches 
conducted with the “fixed” grid. 

Grid for search Click inside the perimeter of the search “grid”. 
Horizontal axis Click on the line representing the horizontal coordinate axis. 
Initial trial/individual 
circle center 

Click on the center point for the initial trial or individual 
circle.  Applicable to circles only. 

Initial trial shear 
surface point 

Click on one of the points that were specified to define the 
initial trial noncircular shear surface. 

Initial trial shear 
surface line 

Click on the line/arc representing the initial trial circular or 
noncircular shear surface. 

<continued on next page> 
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Table 6.1 - continued 

Items that Can be Selected 

Item How to Select Item 
Line load  point Click on the tip of the vector that represents the line load. 
Line load vector Click on the end of the tail of the vector representing the line 

load. 
Line of thrust Click on a segment of the line of thrust - the line of thrust 

represents the location of the “side forces” between slices. 
Material number Click on one of the material numbers located in the area 

beneath the corresponding Profile Line. 
Material region Click in the space beneath the Profile Line. 
Material property table 
boundary grid lines 

Click on one of the four lines around the exterior boundary of 
the material property table to select a boundary grid line. 

Material property table 
interior grid lines 

Click on one of the interior lines inside the material property 
table to select an interior grid line. 

Material property table 
(table text) 

Click anywhere inside the outer boundary of the table of 
material properties. 

N-Most Critical Shear 
Surfaces 

Click on the line or arc representing any one of the “n-most 
critical” (circular or noncircular) shear surfaces. 

Profile line segment Click on a line segment between two points on a Profile Line. 
Profile line point Click on a Profile Line point (symbol). 
Profile line number Click on one of the Profile Line numbers (text); Profile Line 

numbers are located along the Profile Lines. 
Piezometric line points Click on a piezometric line point (symbol). 
Piezometric line 
segments 

Click on a line segment between two points on a piezometric 
line. 

Piezometric line 
number 

Click on one of the piezometric line numbers (text); 
piezometric line numbers are located along the piezometric 
lines. 

Pressure, u  or shear 
strength interpolation 
point 

r Click on one of the interpolation data points (symbols). 

Pressure, u  or shear 
strength interpolation 
triangle 

r Click inside the perimeter of one of the triangles comprising 
the triangulation of interpolation points. 

Reinforcement point Click on one of the points on a reinforcement line. 
Reinforcement line 
segment 

Click on a line segment between any two points on the 
reinforcement line. 

Reinforcement 
longitudinal force 
distribution. 

Click on a segment of the line drawn to represent the 
magnitude of the longitudinal reinforcement force distribution. 

Reinforcement 
transverse force 
distribution. 

Click on a segment of the line drawn to represent the 
magnitude of the transverse reinforcement force distribution. 

Slice Click on the area inside the perimeter of a slice. 
<continued on next page> 
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Table 6.1 - continued 

Items that Can be Selected 

Item How to Select Item 
Slice boundary Click on one of the vertical lines representing the boundaries 

between slices. 
Slope line segments Click on a line segment between any two points on the slope 

line. 
Slope points Click on a slope point (center of symbol). 
Total normal stress, 
effective normal stress 
and pore water 
pressure distribution.  

Click on the appropriate line representing the magnitude of the 
total or effective normal stress or pore water pressure 
distribution along the shear surface.  The distribution is 
represented by a polygon drawn at the base of each slice, click 
on the portion/side of the polygon farthest from the shear 
surface (parallel to the shear surface).  Total stresses, effective 
stresses, pore water pressures may each be selected 
independently. 

Vertical axis Click on the line representing the vertical coordinate axis. 
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Section 7 – MOVING (RELOCATING) ITEMS 
ON THE DISPLAY 

The table of material properties and the text showing the computed factor of 
safety (and side force inclination if Spencer's procedure is used) are initially displayed at 
default locations determined by TexGraf4.  You can relocate these two items by selecting 
them and repositioning them with the mouse (or other pointing device).  The procedure to 
move either item depends on whether the item is the only item located at the point where 
you click with the mouse or if several items exist at that point.  If the item is the only 
item located at that point, you can simply click and while still holding the mouse button 
down, drag the item to a new location.  Release the mouse button when the item is 
positioned at the desired location.  If, instead, several items are located where you click 
with the mouse, you must first select the item to be moved from the pop-up menu that 
appears.  Then, to move the item you must choose "Move" from the Edit menu.  The text 
in the Edit menu normally reads "Move" and is dimmed when nothing is selected.  Once 
you choose either the material property table (lines or text) or the text with the computed 
factor of safety the Edit menu text changes to either "Move Material Property Table" 
or "Move Factor of Safety Text" to reflect what you have selected.  As soon as you have 
selected one of these items and chosen to move it with the Edit menu, a rectangle appears 
with the outline of the item being moved; the rectangle will follow the cursor as you 
move the mouse.  Position the outline where you want the item located.  Click again with 
the mouse to set the new location for the item. 

Except for the material property table and the text with the factor of safety the 
position of all of the other items on the display is controlled by the coordinates for the 
problem, the current scale, and the amount of zooming, panning and scrolling that has 
been done.  None of the other items displayed can be repositioned.  Generally, if you 
wish to create drawings or figures with multiple illustrations of the slope geometry or 
with different slopes on the same drawing, the preferred way is to create DXF files, 
import them into CAD software and, then, use the capabilities of the CAD software to 
reposition items in the drawing. 



Section 8 – “TRACKING” DISPLAY 
TexGraf4 will “track” the cursor and display the values of a variable depending 

on the current selection and position of the cursor.  The values for the item being tracked 
are displayed in the last (fourth) box in the Status Bar at the bottom of the display 
window.  The x and y world coordinates of the cursor are always “tracked” and appear in 
the second and third boxes in the Status Bar.   

The items that can be tracked and the quantities displayed are listed in Table 8.1.  
For tracking to display values you must first activate tracking by choosing “Tracking 
On” in the Window menu.  Note that when tracking is “On” the words “Tracking Off” 
appear as the text for the tracking item in the Windows menu.  

Once tracking is activated the information displayed (“tracked”) depends on what 
is selected; an appropriate selection must be made for tracking to display information in 
the Status Bar.  The required selections and items than can be tracked are listed in Table 
8.1.   

Several items have “alternate” quantities that are tracked when the Shift or Ctrl 
keys are pressed.  Instead of displaying values for the normal quantity, values of the 
alternate quantity are displayed when the appropriate key (Shift or Ctrl) is depressed.  
The alternate quantities that are displayed are also listed in Table 8.1.  You can “toggle” 
between the display of quantities and their alternates by simply depressing and releasing 
the Shift or Ctrl keys in the keyboard. 
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Table 8.1 

Items and Information That Can Be “Tracked” 

 
Item Tracked 

Quantity 
Displayed 

Alternate 
Quantity 

 
Required Selection 

Profile line. Shear strength 
– See Table 
8.2. 

Shear strength 
- See Table 
8.2. 

Select either a point or segment on 
the Profile Line for which you wish 
to track shear strength. 

Piezometric 
line. 

Pore water 
pressure. 

None Select either a point or line segment 
on the Piezometric Line for which 
you want pore water pressures to be 
displayed. 

Pore water 
pressure 
interpolation 
points. 

Interpolated 
value of pore 
water pressure. 

None Select either a point or a triangle in 
the triangulation of points for pore 
water pressure interpolation.  Select 
the specific data set for which you 
want values tracked. 

Pore water 
pressure 
coefficient ( u ) 
interpolation 
points. 

r

Interpolated 
value of the 
pore water 
pressure 
coefficient, . ru

None Select either a point or a triangle in 
the triangulation of points for pore 
water pressure coefficient ( u ) 
interpolation.  Select the specific 
data set for which you want values 
tracked. 

r

Shear strength 
interpolation 
points. 

Interpolated 
value of  shear 
strength. 

None Select either a point or a triangle in 
the triangulation of points for shear 
strength interpolation.  Select the 
specific data set for which you want 
values tracked. 

Distributed 
loads – normal 
stress. 

Normal 
(perpendicular) 
component of 
the distributed 
load. 

Shear stress 
(Shift or Ctrl 
key) 

Select either a point where the 
distributed loads were specified or 
a segment of the outline of 
distributed normal stresses. 

Distributed 
loads – shear 
stress. 

Shear 
(tangential) 
component of 
the distributed 
load. 

Normal stress 
(Shift or Ctrl 
key) 

Select a segment of the outline of 
distributed shear stresses.  Also, if 
the normal stresses are NOT 
displayed you can select a point 
where the distributed loads were 
specified. 

Reinforcement 
line – 
longitudinal 
forces

Longitudinal 
force in the 
reinforcement. 

Transverse 
reinforcement 
force (Shift or 
Ctrl key). 

Select either (a) a point on the 
reinforcement line, (b) a segment of 
the reinforcement line, or (c) a 
portion of the outline of the 
longitudinal force distribution in 
the reinforcement. 

 

<continued on next page> 
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Table 8.1 - continued 

Items and Information That Can Be “Tracked” 

 
Item Tracked 

Quantity 
Displayed 

Alternate 
Quantity 

 
Required Selection 

Reinforcement 
line – 
transverse 
forces 

Transverse 
force in the 
reinforcement. 

Longitudinal 
reinforcement 
force (Shift or 
Ctrl key). 

Select a portion of the outline of the 
transverse force distribution in the 
reinforcement.  Also, if the 
longitudinal forces are not 
displayed you can select either a 
point on the reinforcement line or a 
segment of the reinforcement line 
and the transverse force will be 
tracked. 

Stress 
distribution on 
the shear 
surface – total 
normal stresses 

Total normal 
stress on the 
shear surface. 

Pore water 
pressure 
(Shift key); 
Effective 
normal stress 
(Ctrl key). 

Select either (a) a point on the shear 
surface, (b) a line segment of the 
shear surface, or (c) a portion of the 
outline of  the normal stress 
distribution. 

Stress 
distribution on 
the shear 
surface – pore 
water pressures 

Pore water 
pressure on the 
shear surface. 

Total normal 
stress (Shift 
key); 
Effective 
normal stress 
(Ctrl key). 

Select a point on the outline of the 
distribution of pore water pressure 
on the shear surface.  Also, if the 
total normal stress is not displayed 
you can select either a point on the 
shear surface, or a line segment of 
the shear surface and the pore water 
pressure will be tracked. 

Stress 
distribution on 
the shear 
surface – 
effective 
normal stresses

Effective 
normal stress 
on the shear 
surface. 

Total normal 
stress (Shift 
key); 
Pore water 
pressure (Ctrl 
key). 

Select a point on the outline of the 
distribution effective normal stress 
on the shear surface.  Also, if 
neither the total normal stress nor 
the pore water pressure distribution 
is displayed you can select either a 
point on the shear surface, or a line 
segment of the shear surface and 
the effective normal stress will be 
tracked. 
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Table 8.2 

Shear Strength Information that is Displayed when a Profile Line is Selected and 
Shear Strengths are being “Tracked” 

Shear Strength Option Quantity Displayed Alternate Quantity 
Option 1: Conventional c, φ 
strength 

Friction angle in degrees. Cohesion value. 

Option 2: Linear increase in 
shear strength below Profile 
Line 

Undrained shear strength, c 
(φ = 0) 

None 

Option 3: Linear increase in 
shear strength below 
horizontal reference datum 

Undrained shear strength, c 
(φ = 0) 

None 

Option 4: Constant c/ p  ratio The c/ p  ratio The "intercept" strength, co. 
Option 5: Anisotropic shear 
strengths 

The words "Anisotropic 
Strength" 

None 

Option 6: Nonlinear, curved 
failure envelope 

The words "Nonlinear 
Envelope" 

None 

Option 7: Interpolation of 
shear strength 

The words "Interpolated 
Su" 

None 

Option 8: Two-stage 
strength - linear strength 
envelopes 

The words "2-Stage - 
Linear" 

None 

Option 9: Two-stage 
strength - nonlinear strength 
envelopes 

The words "2-Stage - 
Nonlinear" 

None 

Option 10: "Very high" 
shear strengths 

The words "Very High 
Strength" 

None 

Note:  Alternate quantities are displayed when the Control (Ctrl) key is pressed. When 
multi-stage computations are designated, the strength values for the second and third 
stage computations are displayed when the Shift key is depressed. 
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Section 9 – DXF FILE EXPORT 
TexGraf4 can export drawing information in the DXF file format into an ASCII 

text file.  This file can be read/imported into CAD software for viewing and further 
enhancement, such as addition of supplemental information required to prepare 
presentation quality drawings. 

The information contained in the DXF file will be the same as the information 
that is currently displayed in the main display window at the time the DXF file is created.  
The size of points (symbols) and text will be set so they are in the same proportion to 
other objects as they are on the display screen.  The entire extent of the geometry is 
always included in the DXF file; nothing is "clipped" to the limits of the axes or display 
window.  Before creating the DXF file you may find it advantageous to "zoom" in or out 
so that the text and the symbols have the proportion relative to the overall geometry that 
you want in the DXF file. 

The setting of much of the information regarding the format and content of the 
DXF file is done using the DXF File Drawing Layers, DXF File Line Styles, DXF 
Item Colors and DXF File Miscellaneous items in the Settings menu.  It is generally 
preferable to place different types of items, e. g. Profile Lines and piezometric lines, in 
different "layers" so that the display of this information can be controlled independently 
once it is imported into the CAD software (layers can be selectively turned "on" and "off" 
in the CAD software). 

Layer Names 

Information for various items (Profile Lines, Profile Line points, piezometric 
lines, etc.) can be placed in different drawing "layers" in the DXF file.  The names of 
layers into which each type of item is placed are set using the Settings->DXF File 
Drawing Layers menu item and are stored with the Application Preferences  Layer 
names are strings of alphanumeric characters and must conform to the restrictions on 
layer names imposed by your CAD software.  For example some CAD software restricts 
layer names to numerical values (1, 2, 3, etc.) and may limit the total number of different 
layers that can exist. 

Layer Colors 

Colors are assigned to each layer and item in the DXF file.  The colors assigned 
to each item using the Settings->DXF Item Colors menu item are stored with the 
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Application Preferences.  The numbers for colors must be based on the numbering 
scheme recognized by the CAD software you are using. 

Line Types 

The line styles used for lines in the DXF file are set using the Settings->DXF 
File Line Styles menu item and are stored with the Application Preferences.  The line 
styles that can be assigned in TexGraf4 are set by information in the Graphics 
Configuration File and must conform to line styles that are recognized by the CAD 
software that you are using. 

Points Information 

Points, such as the points defining Profile Lines and the points used for 
interpolation of pore water pressures can be represented in the DXF file in either of two 
ways:  (1) They can be represented as drawn symbols much like they are represented 
when drawn in TexGraf4's main display window and printed, or (2) they can be 
represented as special Autodesk "Point" entities.  When represented as Autodesk Point 
entities, point sizes can be set so that they are a percentage (decimal fraction) of the 
display extent.  Thus, when you zoom in or out, the points can remain the same size.  
Information controlling whether points are represented as drawn symbols or Autodesk 
Point entities can be set using the Settings->DXF File Miscellaneous menu item.  Once 
set, this information is saved with the Application Preferences.  If you choose to have 
entities represented as Autodesk Point entities, you should be familiar with the Autodesk 
system variables PDMODE and PDSIZE.  These variables (PDMODE and PDSIZE) are 
set using the Settings->DXF File Miscellaneous menu. 
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Section 10 – USE WITH MICROSOFT © 
INTELLIMOUSE POINTING DEVICE 
("WHEEL" MOUSE) 

TexGraf4 will take advantage of the "wheel" on a Microsoft IntelliPoint or 
compatible mouse if you have one connected and installed on your computer.  The wheel 
on the mouse is used in two ways, referred to herein as "Modes".  In the first (default) 
Mode the wheel is used to "scroll" the display.  In the second, alternate Mode the wheel 
is used to "zoom" the display in and out.  The alternate mode is activated by pressing and 
holding down the Ctrl key on the keyboard while rotating the wheel on the mouse. 

"Scroll" Mode 

In scroll mode ordinarily the display is scrolled up and down as you rotate the top 
of the wheel away from and toward you, respectively.  However, if you press and hold 
down the Shift key on the keyboard, the display is scrolled horizontally rather than 
vertically when you rotate the wheel. 

"Zoom" Mode 

Zoom mode is made active by pressing and holding down the Ctrl key on the 
keyboard.  In zoom mode the display is "zoomed" in and out as you rotate the wheel.  
The display is "zoomed" in when the top of the wheel is rotated away from you and 
zoomed out when the wheel is rotated toward you.  Each "click" (detent) of the wheel 
will zoom the display in or out by a factor of two (2.0). 



GLOSSARY OF TERMS 
Term Definition and Description 

Application Preferences These consist of most of the settings used by TexGraf4.  
TexGraf4 maintains a default set of preferences and 
additional sets of preferences can be saved and retrieved 
for custom purposes. 

Current Data Set When multiple sets of data have been read into TexGraf4 
and are stored in memory, the Current Data Set is the 
data set for which changes can be made, e. g. the items to 
be displayed can be changed and settings regarding line 
weights, colors, point sizes, etc. can be changed using the 
Settings menu items.  The Current Data Set is slected 
using the Utexas menu. 

Display coordinates These are the scaled coordinates shown on the display 
screen or printed page.  They are typically in units of 
inches or centimeters. 

Graphics Configuration File This is a text (ASCII) file that contains information used 
to "customize" TexGraf4.  This includes information on 
optional line weights and point sizes that can be used as 
well as information on the various line styles that can be 
used for creation of a DXF (drawing) file.  
Documentation is contained in the file itself and you may 
edit the file if you wish. 

Graphics Exchange File This is the file created by UTEXAS4 that is read by 
TexGraf4 to create graphics.  The file is a binary file and 
cannot be edited or altered by the user. 

World coordinates These are the coordinates used to describe the actual 
slope geometry and problem.  They are typically in units 
of feet or meters. 
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